PDA

View Full Version : Exception from IISRT.ISIISInitialize



canice
05-13-2004, 07:44 AM
Hello,

I'm evaluating InstallShield X for our company and I was trying to run a InstallScript project that I had created.

However when I execute it, an exception is thrown by IISRT.ISIISInitialize with error code 0x80040707.

I've tried out some of the solutions in Q104985 but with no success.

I'm running the project on Windows XP SP1.

I did configure the IIS View but it was not associated with a selected feature for the install I was trying.

Any help would be appreciated,
Canice.

Jim Kang
05-13-2004, 12:11 PM
Canice,

That error indicates that iscript.dll (part of our scripting engine) failed to call into another dll.

I have a few questions:

- At the time that exception message box comes up, can you find iisrt.dll or iisrt.ini if you search the temp folder (including subdirectories)?

- What version of IIS is on the system?

- Are the W3SVC and IISAdmin services started before you start running the installation?

Also, can you try the following steps and then run the setup after each step to see if it behaves any differently?

1. Go to Program Files\Common Files\InstallShield\Professional\RunTime\10\00\Intel32 and register everything in there.

2. Delete Program Files\Common Files\InstallShield\Professional\RunTime\10.

If it fails the same way after step 2, is Program Files\Common Files\InstallShield\Professional\RunTime\10 recreated after you're done?

canice
05-13-2004, 01:39 PM
Hi Jim,

1) The DLL and INI file are present as I debugged down through the code until I found the UseDLL() call. I copied the folder path into explorer just to confirm this.

2) I have IIS 5.1 installed on my system.

3) There is an IIS Admin service running, but I just stopped it and tried again and it didn't appear to make any difference.

4) Success!, after registering and deleting the files the installer completed.

Thanks for the detailed help,
Canice.

PS, does the InstallShield X installer not register these correctly, and why should deleting the DLL's matter ?

Jim Kang
05-13-2004, 01:49 PM
I think what happened here was that there was a corrupted install of the engine, but since the actual files were there, the installation didn't notice.

When you deleted the engine files, the next time you ran the installation, it detected that they were missing and installed them (including registration) again.

If you get int this situation again and have some idea what caused the corrupted or incomplete engine install, please let me know.