PDA

View Full Version : msde sa password



cheyenne
04-26-2004, 02:26 PM
I am installing a named instance of msde 2000 with my program and I need to set the sa password. The setting in the msi Property table (SqlSaPwd) is set, but the msde instance has the null password when the application is installed. Is there any way to not have the sa account have a blank password? This is frustrating, it should not default to a blank password!!! Thanks for any help!

oliverb
04-28-2004, 07:24 AM
cheyenne,

You need to create a setup.ini file (if there isn't one already, that is) in the same folder where the MSDE installation program is.

In this file you will add the following text:

[Options]
SAPWD="your password"

When installing MSDE, you must launch the setup.exe using the command line specified below; thus, insuring that the settings file you just created is used.

setup.exe /settings setup.ini

(if this does not work, then append the path where the setup.ini resides. I can't remember if you need to or not).

Good luck and post back here if you have any issues.

cheyenne
04-28-2004, 08:33 AM
Thanks for the info. Unfortunately, I can't have the sa password sitting in clear text in an ini file. It seems to me, given security concerns, that there should be a way to do this that hides the info from the end users. Does anybody know if this is possible in a later version of InstallShield?

oliverb
04-28-2004, 08:55 AM
Try launching the MSDE install in this manner.....

setup.exe SAPWD="your password"

Good Luck,