PDA

View Full Version : How can I find SP4 for W2k?



trugonj
03-10-2004, 11:11 AM
Helo all,

I am creating an instalation package for W2K that needs the SP4 installed in the target machine. Do you know how can I find if the SP4 is installed in W2K?

TsungH
03-10-2004, 11:44 AM
Yuo can use ServicePackLevel property. For a complete list of MSI properties, please refer to Property Reference (http://msdn.microsoft.com/library/default.asp?url=/library/en-us/msi/setup/property_reference.asp)

trugonj
03-10-2004, 12:08 PM
Thank you for your answer, but I do not know where finding this property and how I can use it, could you help me please?

TsungH
03-10-2004, 12:38 PM
I presume you want to check for W2K SP4 before continuing with the installation, and perhaps, abort installation when condition is not met. You will be able to achieve that in Requirements view, under Specifying Target System Requirements view.

trugonj
03-11-2004, 02:35 AM
Hello TsungH,

I am sorry, but I do not understand you very well. You are right when say that I want to check for W2K SP4 before continuing with the installation and abort installation when condition is not met. I specify in the Requirements section the OS (W2K) but I do not find where I can specify the properties of the system, ServicePackLevel in this case. Could you help again, please?