PDA

View Full Version : Error 4075, can't add/remove merge module to project



brian.webb
02-06-2004, 11:55 AM
When I build my project I get error:

File not found. An error occured merging Module [] for Feature 'Always Install'

When I go to the redistributables view the modules have the purple icon with a yellow warning sign on them. When I deselect the module I get a dialog box that says "Could not add Merge Module to Project.", then the module gets unselected. If I check it again I get the same dialog box. I've saved, moved the ise and merge moduels to new folders, etc. Nothing seems to make this go away. I have full admin rights to my computer and it's all on my local machine.

This happens for three merge modules in my project, SOAP, SOAP ISAPI, and MSCOMCT2. It used to give me an error for MDAC 2.6 also but for some reason it's gone away.

The merge modules are there, they're not readonly or anything. I have about 10 merge modules checked in my project and for some reason it's only giving me this error on these three.

I was getting this error in express 4 and was hoping it would go away in version 5 but it didn't. I'm not sure how I got my .ise project into this state?

Does anyone know how to resolve this? Any help would be greatly appreciated, I currently can't build anything...

Thanks,
Brian

Will J.
02-06-2004, 05:28 PM
Have you tried right-clicking the module in the Redistributables view, selecting the "Browse for Module" option, and then browsing to and selecting the specific module?

brian.webb
02-06-2004, 11:21 PM
Yes. I've also tried right clicking and downloading the merge module(s) from the web site, which downloaded but still didn't make the problem go away.

brian.webb
02-25-2004, 03:52 PM
Just to put an end to this if anyone else runs into it. The problem is from a missing merge module that was previously present. If you've selected a merge module previously, in my case I was opening up an old .ise file, and the merge modules are missing you can't remove them. What you have to do is find the old missing merge module and add its location to the search path (or copy the file to a path in the list). Close and restart express then you can uncheck (remove) the module. You can then save and remove the old module.

The bug is that if a merge module is checked and it's missing you can't remove it. You'll get an error in your build even though you can uncheck the module.