PDA

View Full Version : vBuild OCI - Error 0x80010105 The server threw an exception.



Ernie Ocampo
01-27-2004, 10:31 AM
During a vBuild OCI patch I get the following error:

Window Title:
Unhandled Exception
Window Message:
Error Number: 0x80010105
Description: The server threw an exception.
Setup will now terminate.

After the error the software the update was suppose to patch contained a mixture of the older version and newer version. As a result, this causes our application to crash.

Also, I had tried the "CD" differential patch install as well, but when it tried to patch a file that was modified or did not exist the update would fail. I realize this is a limitation that I believe the OCI update will not have. Is there a way to have the update skip files that are changed or missing without aborting the entire update?

Ernie Ocampo

Alon
01-28-2004, 04:42 AM
Regarding the online crash, I need some additional information about it. What was the progress bar status during the crash (scouting/downloading/expanding/installing)? Can we get the various media involved, the OCI type (i.e. what source versions were built) and the end-user situation, i.e. what was installed (you can mail me at alon@redbend.com)? Last thing, what was the Web server configuration (OS, etc).

Regarding the offline update failing during the scout if a source file is not found, and the possibility to allow the end-user or vendor script to ignore and continue --- these are changes that needs to be done in the install shield engine, and a developer from the Professional team should response on this one.

Alon

Ernie Ocampo
01-28-2004, 08:58 AM
Hello Alon,

I discovered that the error is not with the vBuild OCI but with the InstallShield 7 OCI. I am currently working with an InstallShield Tech Support person on the issue now.

The strange thing is that if I run the InstallShield installer via the Setup.exe directly instead of the file Setup.htm file the there is no error.

We tried duplicating my InstallShield project and then removing all the components. We still had the problem.

We then used a new projects default Setup.rul in place of our Setup.rul. The problem did not occur.

This appears to suggest something wrong with our scripts, but I still am not sure why running from the Setup.htm file versus the Setup.exe file causes our scripts to fail. It appears that the Setup.htm file that is generated uses a Setup Player rather than running Setup.exe directly. I am not an HTML expert, but can the problem be related to using an out of date Setup Player? Why would using a Setup Player not allow our scripts to run? How does the HTML/Setup Player launch the Setup.exe?

I have asked these same questions of the Tech Support person and now am waiting for a response.

The next thing I will try is to gradually comment out my code and see when the problem occurs.

Ernie Ocampo