PDA

View Full Version : 0x80040706 error in released product...



kritchie
12-16-2003, 04:27 PM
Error on Win2k machine with SP4:

Unhandled Exception
error: 0x80040706
Object Reference not set
Setup will now terminiate

The above error is occuring immediately as setup starts. My script has not even been run yet. I find it amusing (and frustrating) when looking at the posts concerning this bug and most have to do with InstallShield's own installs of it's products.

This error cannot be reproduced here on any of our machines. A customer is reporting this error. Although this is clearly an InstallShield bug, we are choosing to help our customers. Unfortunately, I have not seen anyway to work around this issue. If anyone has seen a successful way of working around this bug when the product is already released, PLEASE let me know.

Kim Ritchie
very frustrated with InstallShield products...

Frenchy
02-24-2004, 12:42 PM
kim, Did you ever find a solution to this? I am in the same baot as you are.

Andy

kritchie
02-24-2004, 12:51 PM
Hi Andy! Actually we haven't. I think our Tech Support people are just admitting defeat. I did find an Installshield Consumer website that discussed several known issues and this was one of them. It discussed several fixes, the last one being reinstall the OS (yeah right). Short of reinstalling the OS, none of the fixes helped our customers. Best of luck to you!!

Kim

Esquimaux
03-30-2005, 03:38 PM
There is a knowledge base article on this issue:

0x80040706 Object Reference Not Set (http://consumer.installshield.com/kb.asp?id=Q110641)

Maybe it can resolve the issue.

Good luck.

WorkBot
04-26-2005, 10:05 AM
Esquimaux,

Guess what! I followed the instructions in KB Q108322, when I double-clicked the .exe file I downloaded - I got the exact same error.

Now I am really worried.

Win2K server SP3 (5.00.2195)
InstallShield 7.50.100.2014 - ACCPAC ASEE 5.3

I need some help as I can not install (or uninstall) any component of the ACCPAC components on our client's server.

Thanks in advance,
Mike

Esquimaux
04-26-2005, 12:37 PM
Hi Workbot,

Turns out that when I encountered this problem, the solution outlined in KB Q108322 did not work for me either.

I asked the customer that was having the problem to copy the contents of our CD to the local drive and to try installing from there instead of directly from the CD.

When he tried to download the CD image to the target system, he got a CRC error. Turns out that the CD drive was not installed properly and was un-usable. :mad:

To make a long story short, this error can be the result of who knows what problem exists on the machine, its drivers, or even the network security settings.

So all I can say is look at the target system's event logs and try to identify the problem from there. Else...

Good luck.