PDA

View Full Version : help required.... its rgent!!!



kk sonu
12-13-2003, 06:57 AM
hi all,

i m creating a standard project,
i ve to register 3 ocx files ... so i ve made them self register and also set "extract info at built" checked.

i ve set the destination for these ocx files to [system folder]. i also need MDAC and other msi files that i ve dun thru merge module

it compiles sucessfully.

now the problem is:
1] in windows nt 4.o error 1904 arises stating 'Unable to register' for one activeX control [while installing].

2] in other os like profession 2000 98, windows 98 its showing an error 429 "Activex Object cant create object " [while running the product]

i m a bit confused can any one help me out.

thanx anticipating help!!!

regards
kk

jippel
12-15-2003, 01:19 AM
Hi,

I think you don't need to set "Extract info at build" when you use Self Register.

"Activex Object can't create object " means that ocx files haven't been succesfully registered.

-JiPPE

mberterm
12-17-2003, 09:43 AM
Jippel is correct, you would want to use one option or the other, "self register" or "extract info at build". To use both will most likely prevent a completely successful registration which is what the message appears to indicate

kk sonu
12-17-2003, 11:16 PM
Thanx for ur advice
but the problem is still unsolved i ve tried all the permutation and combination with the options available but nothing is working fine

the major issue is that

after removing one of the activex the setup runs fine in Windows NT but not in the other Windows OS


how to solve this!!!!

regards
kk


ps:if possible go thru aother thread posted by me.
http://community.installshield.com/showthread.php?s=&threadid=127622

mberterm
12-18-2003, 09:08 AM
When an installation works on one OS and not on others, many times this is due to...

+ dependencies being available on one OS but not on others
+ OS specific files that work with the one OS but not with others

Can you manually register the OCXs on all the OS types?

Have you tried to isolate the dependencies on the different OS types? KB article Q101515 discusses identifying dependencies.

http://support.installshield.com/kb/view.asp?articleid=Q101515

mr_anderson
12-22-2003, 05:28 AM
Hi KK,

It seems that you have a CreateObject statement in your setup.rul. Can u attach ur setup.rul file?? This might shed some light on the issue. Also try to enclose the CreateObject statatement (if you have any) between try, catch and endcatch blocks.

This might resolve the issue.

Neo.