PDA

View Full Version : minor upgrade uninstall in add/remove programs not caching new script



megheim
11-18-2003, 05:57 PM
I created a version of our project 4.0. I am now creating an installer for 4.05. I am following the protocols for a minor update.
- change the package code
- change the product version
- did the whole custom action
Source: REINSTALL
Target: {} (no space between braces)
- have my command line args set to:
REINSTALLMODE=voums REINSTALL=ALL

Everything works like it should except one big problem. in version 4.0, i had done a whole bunch of custom work for the maintenance mode part (so that the user could perform some custom tweaking to the system, when you accessed it through add/remove programs).

anyway, when i am testing the 4.05 installer, everying is working, however the cached version of the installer that is provided in the add/remove program is still running the scripts that was designed under 4.0, not 4.05. please note however, when i remove the app from add/remove programs (by runing the "4.0" script, it still seem to know to uninstall all the of the extra stuff that was added in 4.05 (although it ran the script from 4.0).

does that make sense? i need for the 4.05 upgrade to replace 4.0 script that gets stored in the add/remove programs.

much, much thanks to anyone who can help!

meg

philiph
11-18-2003, 06:05 PM
I had the same problem, here is the reply from InstallShield:

Paul Merritt: When you run the installation as a minor upgrade it should replace all of the MSI files and thusly replace the script as well. It maybe possible that on this corrupted machine that in the registry there are things that are not allowing this to work correctly.

I have not had time to go back and test this stuff, but according to them it should work as you are expecting it to.

megheim
11-18-2003, 06:16 PM
thank you very much for your prompt reply. i really do appreciate it! while i am sorry that this has happened to you, i'm glad to know that i am not the only one.

unfortunately, i don't know that this is the case for me. i have now tested this scenario on 3 different machines, and yielded the same result. but i will go try this on another, i can only hope that it works!

thanks again!
meg

i will let you know if i find the answer!

philiph
11-19-2003, 10:25 AM
I am definatley interested in your results since this could pose problems for us. If you find that the newer script is not running I may have to test and reopen my case with InstallShield. Like I said, I just plain haven't had time to test what they told me.

megheim
11-19-2003, 01:08 PM
Hi again Phillip!
I'm sorry to tell you, I did yet another test and still am not having any luck. I don't know what the problem is. i was thinking about opening a case with installshield myself, but time is extremely important right now. We may be in a position that we can just punt on this one. When you do a remove, it does uninstall the newest upgrade (and associated files). Leaving the custom fucntionality there in script from before won't ruin anything (it's just no longer needed). It just makes things a little uglier than they should be.

If you do find something out, I am all ears. I would love to have clean system.

We plan to upgrade to the new Dev Studio for our next release, I am really hoping this issue will just disappear then!

Thanks again for your feedback!
Meg

Flowers
11-19-2003, 01:22 PM
Hi

I had this problem myself and solved it. See my thread at:

http://community.installshield.com/showthread.php?threadid=122920&highlight=setup.inx

philiph
11-19-2003, 01:36 PM
Thanks for the help and information.

tcima79
01-14-2004, 01:00 PM
I have experienced this problem too but the only solution I have found to it so far is to upgrade to a newer version of InstallShield such as DevStudio 9. I surely hope this is not the only solution though...

Flowers
01-17-2004, 11:01 AM
We currently need to manually copy setup.inx in OnResumeUIAfter to the target machine to make sure the new script is executed for uninstalls. Does DevStudio 9 do this automatically?

tcima79
01-17-2004, 12:59 PM
I can't answer that. All I know about DevStudio 9 comes from the evaluation I did on behalf of my company. If you have not yet evaluated this program, I recommend downloading an evaluation version and testing for the specific scenarios you're interested in to see if the program suits your needs. The best part of this is you get free technical support for the duration of your trial, so take advantage!

Hope that helps...

philiph
01-19-2004, 10:29 AM
From my experience, the application does not work as expected. I work in a very small company and we don't have time to work out all of the bugs in InstallShield so we have pretty much disregarded this problem.

The problem:
Create an installation and a minor upgrade. Run the installation on the target machine. Add some files, replace some files and rebuild the installation. Now run the installation, which should run in upgrade mode, on the target machine. Delete some of the key files that were installed on the target machine, specifically delete a file that was added to the upgrade. Run a repair through Control Panel..Add/Remove Programs. The new files will not be replaced, any stuff added to the installation after the first time it was run will not be replaced/added.

If you are about to demo this product then I suggest you pound it pretty hard. Make sure that the software does EVERYTHING that you want it to do, and test it to make sure it does what it claims. If I had one second of spare time I would move our installation to something else.

tcima79
01-19-2004, 12:33 PM
You hit the nail on the head! InstallShield definetely does not work as advertised in a number of situations... however there isn't anything better out there that I know of so the idea of moving to something else is wishful thinking at best (to my knowledge)...

sagmam
06-16-2004, 11:12 AM
Hi all,
I have a similar prob, but not with uninstalls... It's like you said: I build a package, I do some changes, I build a new version.
I install the first version, then I install the second one (I don't uninstall anything manually). I can see, using the debugger, that the wrong script is running (there are inconsistencies between the code I see in the debug window and the code that is actually executed).
The project is an MSI InstallScript project.
What do I do in order to make my new script run? Copying setup.inx in OnResumeUIAfter is a little too late, isn't it?

Thanks.