PDA

View Full Version : vRoots not getting removed on uninstall



roskuski
11-10-2003, 02:40 PM
I have two IIS Virtual Roots that I create on installation and have marked to be removed on uninstall. However, they are not being removed on uninstallation. There is an error about not being able to access a registry key/value in the log file that I will include a snippet of below. This key/value does not exist on the traget system when the product is installed. Any Ideas on what could be going wrong here?

This is version 7.04.

MSI (s) (9C:08): Executing op: ActionStart(Name=caRemoveVRoots,Description=Removing IIS Virtual Roots...,)
Action 14:09:25: caRemoveVRoots. Removing IIS Virtual Roots...
MSI (s) (9C:08): Executing op: CustomActionSchedule(Action=caRemoveVRoots,ActionType=1025,Source=BinaryData,Target=RemoveIISVRoots,)
MSI (s) (9C:08): Creating MSIHANDLE (10) of type 790536 for thread 1544
1: Could not retrieve data from Registry value: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield Uninstall Information\{15132A17-29F0-4E1A-A487-E668305F37E7}_IS_IIS:RootsInfo
MSI (s) (9C:08): Executing op: ActionStart(Name=RemoveFolders,Description=Removing folders,Template=Folder: )
Action 14:09:25: RemoveFolders. Removing folders

huntant
11-24-2003, 01:48 PM
I'm experiencing this as well. Have you had any luck resolving the problem?



Anthony

roskuski
11-26-2003, 09:07 AM
I have not had any luck with this so far. I seem to remember it working early on in the development process of my installer, but at some point it stopped working.