PDA

View Full Version : build IS project on another PC problem



swantest
11-10-2003, 10:58 AM
I got a following problem. I have created InstallScript project on one PC. Then I install the same license of DevStudio on another PC (both under win2000), and uninstall DevStudio on the first PC. After this I cannot even open my project on second PC, all that I got is "Class not registred" in output window.
Any suggestions, whats wrong?

Thanks in advance.
Alex

RichAquino
11-10-2003, 01:05 PM
Hi Alex,

Can you open any projects?

Rich

swantest
11-11-2003, 03:04 AM
Thank you for reply.

Finally I found that after re-install my DevStudio on another PC, it is working in strange manner. When Iam trying to create new InstallScript Project:
1. File->New, then I Select InstallScript Project and press OK.
2. 'Class not registred' appears in output window.
3. 'Save As' dialog box appears with My Project Name-1 in File Name field, but My Project Name-1 is already in current directory, so when I press Save, 'Do you want to replace it?' message appears.
4. After Save As My Project Name-1.ism project file, I can successfully open this project, but it is not working properly.
5. For some reason My Project Name-1.ism saved on disk in binary, not XML format, but then I try to go to General Information->Project Properties DevStudio failed. It also failed then I click Product Properties, and when I click Setup Types, and many other items in my View List.

I found only two difference between these two PSc. First of them is under Win2000 (no Service Pack installed) and with Visual Studio 6. Second is under Win2000 Service Pack 3 and Visual Studio .NET 2003.

Please Help, what wrong with my DevStudio9. Is it some licensing problem? or may the reason of problem is compatibility with Visual Studio .NET 2003?

RichAquino
11-11-2003, 03:32 PM
Hi,

Does this only happen for InstallScript projects, or all objects?

Rich

swantest
11-13-2003, 07:53 AM
Yes it is happens with any type of projects. I still not be able to solve this problem on this PC, on other computers in my office I can install IS DevStudio correctly.
I only got problem on this computer only. This is Pentium IV; 2,33 Ghz; 1Gb RAM, under Win2000 Advanced Server SP3, with MS VC .NET 2003 installed.
Please help!

Alex

alex42
11-13-2003, 08:07 AM
This is just a guess, but try to register msflxgrd.ocx:
regsvr32 msflxgrd.ocx in command line

I had some trouble with earlier Installshield versions when this wasn't registered.

I don't think its a licensing problem...I can install DevStudio just fine on 2 PCs, but you can only have one instance running at a time.

swantest
11-13-2003, 09:29 AM
Dear Alex42,

Your idea is help me to solve this problem. Thank you very much!
Now DevStudio works ok.
For some reason msflxgrd.ocx was not just unregistred in the system, but not exist in my system at all. I copied this file from another machine and then register it and now it works.

It looks like a real bug in DevStudio.

Regards,
Alex L.

swantest
11-13-2003, 11:07 AM
Unfortunately, registreting of msflxgrd.ocx solve not all problems. It fix the problem with browsing of View List. But 'Class not registred' error still appears when I try to open previously created project saved as XML. It seems like DevStudio generate 'Class not registred' error everytime when I try to open or save InstallScript project in XML format.
I need one more advise. I think my system missed not only msflxgrd.ocx.

PLease help!

Alex

RichAquino
11-13-2003, 05:00 PM
Hi Alex,

Can you try this:

1. Uninstall InstallShield DevStudio.
2. Register msi with this command line:
msiexec.exe /regserver
3. Reinstall InstallShield DevStudio.

Rich

swantest
11-14-2003, 06:15 AM
Hello,

Unfortunately it does not help me, I still unable to open or save any XML project, I only get "Class not register error". This message is not informative. What the name of this class? It looks like DevStudio failed to parse XML.

Alex

RichAquino
11-14-2003, 04:14 PM
Hi,

We found an issue where, if MSI wasn't registered properly, parts of our installation would fail (silently). In particular, the part that installs the XML parser seems to have failed for you.

Try downloading and installing MSXML 4.0 from Microsoft's site. That should get it working...

Let me know if this link doesn't work. (http://www.microsoft.com/downloads/details.aspx?FamilyID=3144b72b-b4f2-46da-b4b6-c5d7485f2b42&DisplayLang=en)

Rich

swantest
11-19-2003, 08:26 AM
hello RichAquino,

Thank you.
After installing MSXML, DevStudio working normally.