PDA

View Full Version : Files get copied to install dir, but ActiveSync not launched



ElCortez
10-30-2003, 02:10 PM
I've created a Basic MSI installation with a Windows CE redistributable. When I run it, the files get copied to my install dir on the desktop, but ActiveSync is never run to install the app on the target device. I've added a couple of custom actions (via a standard DLL that uses the RAPI) that write some registry entries to the device right when the user clicks the InstallNow button of the ReadyToInstall dialog, but that shouldn't make a difference (should it?). Even when I make it so these actions aren't performed (condition = 0), ActiveSync still doesn't run.

The only thing I can think of is that somewhere one of my customizations whacked the spot where ActiveSync is called. Is there somewhere in DevStudio that I can check/modify/fix this?

One extra note - I'm getting a warning (1527) that no files are included in the project, but presumably that's normal if all of my files are included in the redistributable.

Any help would be greatly appreciated.

Thanks,
Curt

ElCortez
10-30-2003, 06:39 PM
Well, I've used the MSI Debugger in DevStudio to break right before the call to InstallCEApps.XX..., and the funny thing is that it does get there. It just seems to not do anything. Doing a Step Over takes me to the next step (InstallFinalize) pretty quickly.

I created another CE installation package, this one consisting of only an executable, and stepped through its install. After doing a Step Over at the InstallCEApps.XX..., the Add/Remove Programs dialog showed up (as it should). The next step shown in the MSI Debugger was InstallFinalize as well.

What I'd really like to see now is what the CEAppManager thinks is going on. With hand-written installations I've done in the past (no InstallShield), I could call CeAppMgr.exe with the /report flag to see debug info. Is there a way to turn on this debug info when using DevStudio?

- Curt

ElCortez
10-30-2003, 07:41 PM
Okay, I got it. The whole problem was that in the CE Object settings, I had my company name as "ViaSat, Inc." As soon as I changed it to just "ViaSat", everything worked. I wasted a whole day figuring that out! Grrr....

Anyway, I'd like to put in a request that InstallShield make the following mods:

1) Warn the user in the CE Object Wizard about invalid characters.

2) Make an easy way to turn on debugging for the CE App Manager.