PDA

View Full Version : Installscript engine version problem



xyding
10-29-2003, 03:28 PM
I am trying to install a software application and I got this error message. "The Installscript engine on this machine is older than the version required to run this setup . If available please install the lastest version of Isscript.msi or contact your support personnel for further assistance."

Thanks for any help.

Mark at IS
10-30-2003, 08:15 AM
For a possible solution to this problem, please visit http://consumer.installshield.com/kb.asp?id=q108158.

EMoscosoCam
11-19-2003, 12:50 PM
I have just migrated a version 7 to version 9 (SP1) and the same error message appears.

I even tried installing the engine by hand by using isscript9.msi (2003-11-11) and the error persists. Included in the Setup is the merge modele of the engine (also 2003-11-11).

I also tried deleting the folder where the engines resides in the target machine and eventhough the Setup installs the engine, the error message still appears.

The target machine is Windows XP.

What can I do?

xyding
11-21-2003, 02:15 PM
For now, I go back to Installshiled 7 and won't use version 9 until this problem is resolved, I guess, by Installshield.

Pranali Bhatt
11-21-2003, 03:04 PM
Hello,

I am not able to reproduce the particular issue with DevStudio 9 Service Pack1 inhouse. It will be helpful if you can send me your setup media at: pranalib@installshield.com.

I will get back to you as soon as I have any updates after receiving your setup package.

Thanks,
Pranali

EMoscosoCam
11-21-2003, 03:18 PM
Thanks a lot for your interest.

I cannot send you the file since the installer weights 90Mb.

Pranali Bhatt
11-21-2003, 03:19 PM
Hello,

Can you please upload it to installshield ftp site? I will download it from there.

Thanks,
Pranali

EMoscosoCam
11-21-2003, 03:40 PM
Ok; I will do so next week.

I had to return to IS Developer 7 SP4 in order to make a deployment this weekend. I would have to reinstall version 9 in order to make a new setup.

What could be the reason that even installing the latest engine by hand that message still appears?

On best regards,

Ernesto Moscoso Cam
Lima, Peru

Pranali Bhatt
12-02-2003, 11:20 AM
Hello,

I was wondering if you had a chance to upload your setup package at InstallShield ftp site. Please let me know when you upload it.

Thanks,
Pranali

mattaberle
01-21-2004, 08:52 PM
My issue that the app install is running a check on something and prompting to install the new engine. Does anyone know a way to run the IsScript.msi as the first action of the original msi so the check passes and install continues? or maybe a way to transform the manufacturers .msi. This particular package is the first of between 4 and 8 being deployed in sequence and using another package would drive me nuts trying to work the pre-req's for a Zen deployment.

Thanks

Fabio Pagano
02-23-2004, 04:41 PM
Generate a new package code at every build.

Look at http://community.installshield.com/showthread.php?s=&threadid=122572&perpage=5&highlight=generate%20and%20package%20and%20code&pagenumber=3

doccider
01-21-2008, 07:18 PM
I am trying to install a software application and I got this error message. "The Installscript engine on this machine is older than the version required to run this setup . If available please install the lastest version of Isscript.msi or contact your support personnel for further assistance."

Thanks for any help.What am i to do about this ? email me at : workmanterry@yahoo.com