View Full Version : Digital Signature not working on single file exe

10-27-2003, 07:52 AM
I have created a single-file exe media, and am prompted for my password which I enter. I then see the error
ISDEV : warning -5032: Failed to sign the self-extracting executable file.

Sure enough, right-clicking on the .exe shows that there is no "Digital Signature" tab.

If I use the iSign.exe program to do this step manually, it claims "Succeeded", but again, there is no "Digital Signature" tab. It looks like the time/date of the file has been updated, but no digital signature applied.

I am using a .spc and .pvk file for the signing credentials certificate and private key - all has been well in the past using these in the Package For The Web program.

Any ideas?

10-27-2003, 01:06 PM
Hi Alex.

I wasn't able to reproduce your problem here. The digital signing of a self-extracting exe worked for me without error.

iSign is primarily used for signing .hdr files. The build is actually using signcode.exe to sign the self-extracting exe. You might want to try using signcode.exe and see what kind of error you get.

Also, make sure your signing credentials have not expired.

10-28-2003, 08:17 AM
Thanks. I used the SignCode.exe program and it still failed on the build machine, but I was able to apply the signature to the package file from another machine...

The main difference between the two machines is that the one it works on has Win2K SP4, the other has Win2K SP2. Also, the working machine has PackageForTheWeb4, whereas the bad machine has PackageForTheWeb2. Would these make any difference? Should I bring the main build machine up to Win2K SP4?


10-31-2003, 12:59 PM
Sorry for the delay in getting back to you. I was able to reproduce the problem you described. The signing fails on Win2k without SP4, but succeeds when SP4 is installed. If you can upgrade your build system to SP4, the digital signing should work without error.

I will try to get SP4 on Win2k documented as a requirement for digital signing. Thanks for your patience.

12-17-2003, 04:09 PM
I also got -5032. After seeing this post, I downloaded Win2K SP4, but I got the same error. I was able to sign with no problem by running signCode.exe outside the DevStudio 9.0. Yes, the error only occurs with signing Single File EXE. I want use post build option to upload the file to our update server. It would be nice that signing Single File EXE works in the IDE. :confused: