View Full Version : CopyFile always returns 'Access is denied' in Win98 even though file is copied

10-24-2003, 03:43 AM
I have an InstallScript project that installs a number of files by copying them from a website (using CopyFile). When the installation is run in Windows XP it works perfectly. When I run the installation in Windows 98 (and Windows ME) CopyFile always returns the error code 0x80070005 (Access is denied) even though the files are successfully copied (I have verified that the files don't exist before the installation, and that they do exist after the installation). This results in the files not being logged, which means that they aren't removed during uninstallation. I've tried using XCopyFile instead of CopyFile, but it behaves exactly the same way.

What can I do? Is there a simple workaround for this bug? I want to avoid writing lots of script code for logging and deleting the files myself...

10-24-2003, 11:56 AM

Is this a different problem than the one you're working with Devin on in this (http://community.installshield.com/showthread.php?s=&threadid=124940) thread? If not, please continue to work in that thread. There's no need to create a new one.


10-27-2003, 09:47 AM
Oh, sorry about that. After a couple of days with no response I assumed you considered that thread closed. Technically, the reason why the files aren't logged (being the problem discussed in that thread) was in fact found, so I thought I'd start a new thread dealing with the origin of the problem (invalid error codes from CopyFile).