PDA

View Full Version : Unwanted shutdown after install



hill_t
10-23-2003, 01:36 PM
I have a report of one machine that always will shut down at the end of my install. This only happens on one machine and this is not a desired effect. I've searched the log file and can't find any errors. The only items of interest are shown below. Any and all help is greatly appreciated.


MSI (s) (58:68): MainEngineThread is returning 0
MSI (c) (3C:34): Back from server. Return value: 0
MSI (c) (3C:34): Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
Action ended 11:00:02: ExecuteAction. Return value 1.
MSI (c) (3C:34): Doing action: ISSetupFilesCleanup
Action start 11:00:02: ISSetupFilesCleanup.
MSI (c) (3C:34): Creating MSIHANDLE (58) of type 790542 for thread 3380
Action ended 11:00:02: ISSetupFilesCleanup. Return value 1.
MSI (c) (3C:34): Doing action: SetupCompleteSuccess
Action start 11:00:02: SetupCompleteSuccess.
Action 11:00:02: SetupCompleteSuccess. Dialog created
Action start 11:00:05: ISCleanUpSuccess.
Action ended 11:00:06: ISCleanUpSuccess. Return value 3.
DEBUG: Error 2896: Executing action ISCleanUpSuccess failed.
Internal Error 2896. ISCleanUpSuccess
Action ended 11:00:06: SetupCompleteSuccess. Return value 3.
Action ended 11:00:06: INSTALL. Return value 1.
MSI (c) (3C:34): Closing MSIHANDLE (1) of type 790542 for thread 3380

lsmeteor
10-23-2003, 04:33 PM
Hi,

I am not sure what this all means but I got these codes below from a document I downloaded from MS (wininstaller.doc)

the possible return codes are:
Value Description
0 Action not invoked; most likely does not exist.
1 Completed actions successfully.
2 User terminated prematurely.
3 Unrecoverable error occurred.
4 Sequence suspended, to be resumed later.

There is no further specific explanation on possible causes.

hill_t
11-05-2003, 03:33 PM
Upon further investigations this is only happening when doing a REINSTALL. I've had no success in finding any possible causes or fixes for this issue so far. If anyone else has seen this during a REINSTALL before or has any ideas I'd be happy to hear them!