View Full Version : Error -2147220718 With MSDE 2000 Install

Gareth Horton
10-16-2003, 09:22 AM

I am using Devstudio9 with a converted project from ISPro 6.31.

I Removed the old MSDE 1.0 object and replaced it with the MSDE 2000 object.

The MSDE install failed on the Win 2003 test machine, so I threw in some error checking.

The object seems OK at the OnBegin event.

The object fails when checked at the OnMoved event with
the abovementioned error number.

Additionally I get

A blank error.Description
error.file is M:\BldRoot\source\ObjectsPro\MSDE 2000 Object\Script Files\setup.rul

Line is 576 and script error is -1.

I don't have an M drive mapped or a path like that.

Any ideas, or is it back to 6.31 after 2 hours of Devstudio?

Thanks in advance



The install works fine on WinXP - but fails on 2003 Server Std

10-18-2003, 03:39 AM
Gareth Horton,

The line is question is the line that launches the MSDE 2000 redistributable from Microsoft (using LaunchAppAndWait), so this indicates that LaunchAppAndWait is failing.

Typically the next step would be to install the source of the MSDE 2000 object and debug, but unfortuantely this source was accidentally ommitted from the DevStudio9 object source release.

You might also want to check TARGETDIR in this scenario to see if the MSDE exectuable was installed and if it is launchable manually.

You could also create a trace file and Email it to me (devin@installShield.com). I will decrypt it and determine exactly what path and file LAAW is trying to launch.

The setup will automatically create a trace file on the desktop with the name SetupXXX.bin, if you create an "ISLogit" key under HKCU and then run the setup. Please Email me this file.

Devin Ellingson
InstallShield Software Corporation

Gareth Horton
10-20-2003, 03:38 AM

Thanks for looking into this.

I have emailed the trace file.

As you mentioned, it does not look like the files ever get transferred to the temporary subfolder of TARGETDIR.


02-03-2004, 03:22 PM
I'm facing the same situation, any chance the solution can be shared?

Gareth Horton
02-04-2004, 04:41 AM
Sorry, no solution as yet.

I am still waiting on Devin and have given up on the project in the meantime. I have gone back to MSDE7 with IS 6.31, which works fine.

I think I might have got it to work at some point by copying the full msde install in a specific place in the install , but it was somewhat dodgy for production purposes so I left it.

I am witing to see if a service pack fixes it.

This is what I got from Devin on the trace

Here is some information from the trace that shows the command line that LaunchAppAndWait is trying to use:

ISFuncEnd|LaunchApp|Result=Failure Error=0x00000003 Program="C:\Program Files\Datapump Server\E09B48B5\MSDE2K\Setup.exe" CommandLine=SAPWD=17tYtddafd435 REBOOT=ReallySuppress /wait Options=49

So you could try an see if copying the setup.exe to TARGETDIR\E09B48B5\MSDE2K\ works, or try and monitor where it is trying, as the E09B48B5 might be package specific or something.


02-04-2004, 05:49 AM
This might seem like a daft question but is there any reason you dont use the merge module? You can set all of the options required with the Object Wizard ... if you use a setup.exe you need to use an ini file as well to configure MSDE.

Or does the merge module have the same problem?


Gareth Horton
02-04-2004, 07:20 AM
Here is a reason for not using merge modules.


Just to clarify, I am not trying to use the setup.exe directly, I am trying to use the InstallShield Object for MSDE 2000, which is a wrapper around the MS setup.exe, but it is failing on Windows 2003.

Another interesting article I found on the knowledgebase (Q110520)
is that this problem existed in Professional 7, but claims to be fixed in Devstudio 9.

Their versioning is no quite right as they say 2.01 is the affected version, but 4.0 is the version on Devstudio.

In the info for that object on my copy of devstudio it says

Object Author: InstallShield Software Corporation
Name: InstallShield Object for MSDE 2000
Version: 2.01
Date: May 8, 2003


02-04-2004, 11:59 PM
Hey guys, the solution does exist. It involves modifying the MSDE 2000 Object template. This solution worked for me just fine, although I found another problem - MSDE2000 is not getting installed on Windows XP.
Anyways, here comes:

This is a known issue in the MSDE 2000 object and a work order has been created on this bug(1-JCH2L ), but for now you just need to follow these steps to incorporate the fix...

1.) Go to the update service and make sure you install the 'InstallScript Objects Source and Customization Wizard' for DevStudio 9. If you have problems with this, you can go here...

2.) Run the installation and make sure you install the template for the MSDE 2000 object source.

3.) Then click on the 'Start->Programs->InstallShield->DevStudio 9 Tools->InstallScript Object Customization Wizard' and proceed to create a new object project based on the MSDE 2000 object.

4.) Once you have your new object project created, click on 'Project->Settings...' and click on the Platforms tab. Select Windows Server 2003 and click okay.

5.) Now click on the 'Organization->Components' view and click on the 'SQLServer2000 Files' components. For the Operating Systems property, make sure you add Windows Server 2003 support.

6.) Rebuild the object project and include this new object into your installation project and it should now work properly.

Hope this helps.

Using IS support service was pretty rewarding experience so far. Wish I could say same thing about using the IS DevStudio...

02-05-2004, 12:26 AM
I just played the same game with modified MSDE2000 object - modified template. It appears that the object requires SP 1 for Windows XP, which is a bit of a surprise for me. It will return status OBJ_STATUS_OSINVALID if you don't have SP 1 installed.

To me it looks like redundant requirement and I just commented out the part where SP 1 is getting checked. Just tried test install on WinXP without SP1 - looks fine.

We also had IS 6.31 project with MSDE 1.0 object, but for new version of the product we want to move to MSDE2000 for number of reasons. Such as:

- Customers with Windows 2003 Server complain that installation warns them about incompatibility of MSDE 1.0 and Win 2003. One customer even complained of loosing COM+ repository over our old installation.

- The speed of MSDE 1.0 without service pack installed is terrible and with latest MDAC components it gets even worse. In general MSDE 1.0 installation was the most significant drag for our support department.

Gareth Horton
02-05-2004, 03:36 AM

Thanks very much for sharing this.

When I originally downloaded the templates, the msde2000 was not included.

I am going to download the (presumably) updated file now.

I also went through support on this issue, but with no success.

Thanks again.