PDA

View Full Version : Bug? CPU usage goes to 100% when selecting "import REG file"



AlexLee
10-10-2003, 05:06 AM
I have a few registry entries that I want to put into my install project, and I happen to have then in a .reg file.

When I right click in the Destination Computer's registry view, and select "import REG file", the CPU usage goes to 100% and DevStudio stops responding. I have to kill the program and start again.

Am I doing something wrong, or is this a bug?

Alex

RichAquino
10-14-2003, 01:21 PM
Hi Alex,

Can you reproduce this every time? I cannot reproduce it at all. You should see a wizard when you click Import REG File.

Does it only happen with a particular project, or project type? Or, can you reproduce it with any project or project type? Are you able to see other wizards (release, component, ...)?

Rich

AlexLee
10-15-2003, 02:15 AM
Hi Rich,

Yes, it happens every time... however, it is limited to when you preform the action on a sub-key and not on the top level keys.

I have raised this with the InstallShield support staff, and it has been confirmed and they have given it a reference number WO#(1-G1ZK9)

Alex

jsanders
01-26-2004, 11:47 PM
Is there any new information on this bug? I built my projects several weeks ago and had no problems importing the registries then but now my system hangs and I have to kill DevStudio using the Task Manager. I am pretty sure that this is not machine specific since I have had this happen on two different machines with two different projects.

Jay

jsanders
02-02-2004, 05:34 PM
This bug has been the bane of my existence for the past month. It only seems to happen when I have a big deadline and have to import a big registry file.

Whenever this happens I get two instances of DevStudio in my Task Manager.

I have tried creating a new registry set and I will be allowed to open the Import Registry Wizard, but none of the new registry data is included after the import.

adlibedoc
07-29-2004, 02:56 PM
any news on this? it is driving me insane.

crowland
08-18-2004, 05:24 AM
I've just hit this problem and found this forum - and a guide to a work round.

The bug seem to be triggered whenever a position in the registry tree lower than HKLM is choosen, eg HKLM\Software

Fortunately the entries in the .reg file are full paths, not relative so the registry import works fine if initiated from higher in the registry tree.

Chris

Tyboard
06-30-2005, 02:29 PM
My DS seems to be fine for a little bit but it soon goes to 100% and will not come down until I close it completly. I have a P4 2.8 512ram laptop that I do must of my dev work on. I would not be so bad but being at 100% makes my laptop get very hot and thats just not good. If I open a project but don't do anything with it and its minimized it will soon goto 100 and I have to close DS.
I wish there was a away to fix this its a real pain.