PDA

View Full Version : Bug?? Radio buttons cause build error in DevStudio9 for VS.NET 2003



DannonGruver
10-09-2003, 01:20 PM
Radio buttons seem to be causing a build error for DevStudio 9.0 for VS.NET 2003.
I get a -6034 build error.
This is only happening for InstallScript-type projects and only happens in VS.NET.
The only output related to the error in the Output window is:

C:\Program Files\InstallShield\DevStudio 9\IsDev.exe\-6034
ISDEV : fatal error -6034: Internal build error

The Error Documentation says that this is an upgrade warning but the project is not an upgrade, i.e. I get the error when i build an InstallScript project from scratch using DevStudio9.
Also I'm getting a build error not a warning.

Can anyone help?


NOTE: To recreate the error:
1) Open a new InstallScript project.
2) Create a new Dialog for the User Interface.
3) Add a radio button group and 1 radio button to the new Dialog.
4) Build.

hidenori
10-14-2003, 07:05 PM
I can reproduce the problem in house. I am still looking into it why this is happening. I will post more informaton when I figure it out.

Regards,
Hidenori Yamanishi
InstallShield Software Corporation

hidenori
10-17-2003, 07:43 PM
I apologize for taking so long to figure it out... The issue is that the type library for an InstallShield DevStudio system component is not registered correctly. To resolve the problem temporary, please run the attached reg file. I also submit a work order #1-G7WGA to address this issue in the service pack.

Thank you.
Hidenori Yamanishi
InstallShield Software Corporation

DannonGruver
10-20-2003, 09:35 AM
Wow!! Nice job Hidenori. That fixed it.

Thank you for your help.