PDA

View Full Version : The InstallShield Engine (iKernel.exe) could not be launched. Library not registered



kctopgun
10-01-2003, 01:30 PM
Hello,

I've got this error when trying to run a IS 6.2 setup:

"The InstallShield Engine (iKernel.exe) could not be launched. Library not registered."

What is the problem here?

Thanks for all help.

Old Nick
11-01-2005, 05:07 AM
I see many threads in this forum quoting this or a similar problems, they are all unanswered by InstallShield Reps. Is there nobody out there (from Installshield or otherwise) who can give a difinitive answer to this problem.

My problem is that when I go to update my copy of ISS's "BlackICE PC Protection" I get the error message "The Installshield Engine (iKernel.exe) could not be launched. No such interface supported". I do not know which software programme installed "InstallShield" on my computer, so I don't know who I can turn to for assistance.

Action tried:
I renamed C:\Program Files\Common Files\InstallShield to InstallShield_old, then tried to update Blackice again, whereupon a new InstallShield folder was generated but I get the same error message.

System details:
OS Windows XP SP
InstallShield's Engine IKernel.exe (version 6.31.100.1221), [the re-generated version is 6.31.100.1190].

Derek Nicholson