View Full Version : Set Dr Watson as default debugger (V. V. Urgent)

08-05-2003, 03:39 PM

Very Urgent.

Please, help me to set Dr Watson as default debugger on Windows NT and Windows 2000.

I tried the following script

nResult = LaunchApp(WINSYSDIR ^ "regsvr32.exe", "/s" + WINSYSDIR ^ "drwtsn32 -i");

// do i have to do this step at all
nResult = LaunchApp(WINSYSDIR ^ "regsvr32.exe", "/s" + WINSYSDIR ^ "drwtsn32.ocx");

It is updating the registry if i go to Start/RUN and type drwtsn32 -i

How do u set it through install shield script. for NT and 2000.


08-06-2003, 06:58 AM
You might want to try:

LaunchApp("cmd.exe", "drwtsn32 -i");

You may have to give the path to cmd.exe or use ChangeDirectory to set the directory containing cmd.exe as the current directory.

08-06-2003, 09:03 AM

Thanks for the propmt reply very much.
But when i try this it doesn't work.

It will open cmd.exe and just wait there

i have to manually close the command prompt. it did not register anything.

I want it to set drwtsn32 as default degubber in sikent mode such that no need for use to close the drwatsn dialog.


08-06-2003, 12:36 PM
I got it to work using the following:

LaunchApp("drwtsn32", "-i");

However, it pops a message box indicating that Dr. Watson has been installed as the default application debugger. I have not found anything that will set the debugger silently.

08-06-2003, 12:53 PM

Thank you very much for the reply. But, I want it in silent mode as it is more userfriendly. Anyway, i am trying this to directly change the registry. I have to test it though.

// for setting Dr watson as default debugger
subkey = "SOFTWARE\\Microsoft\\WindowsNT\\CurrentVersion\\AeDebug";
nResult = RegDBSetKeyValueEx(subkey,
"drwtsn32 -p %ld -e %ld -g", -1);

I will let u know how it works. Do u see any problem doing this??


08-06-2003, 02:48 PM
I believe you also have to set the value for "Auto" in that key to 1.

Good luck.