PDA

View Full Version : searching for "COM" or "COM+"



graven
07-14-2003, 09:04 AM
hi there,

i'm trying to search the forum
http://community.installshield.com/forumdisplay.php?s=&forumid=45
for the terms "COM" or "COM+".

i tried with and without quotes for the search terms - no hits.

is there any special secret search syntax so i don't get a single hit?

i checked manually: there's several threads covering that topic. i just don't get any search results!

regards, graven

KellyF
07-15-2003, 11:32 AM
COM was listed as one of the "non-indexable" words by default in our forum software. This means that any post for COM going forward will index it... however, for historical posts, I'll need to re-index the forums which can take hours.

Since I have to work on something else this weekend, I'm leaning toward kicking off re-indexing on Saturday. I'll do it in chunks if possible...

KellyF

KellyF
07-18-2003, 10:51 AM
Ok. The search restrictions have been modified so COM is now searchable, however, I still need to fully re-index the threads. I'll need about 4 hours some Saturday or Sunday to complete this. (only about 1/3 of the threads were completed this morning)

As of the moment, it finds some items on COM, but will not be fully complete until perhaps next Monday. (I can't say whether I'm going to work on Saturday or Sunday yet)

KellyF

KellyF
07-19-2003, 09:45 AM
Ok. The search indexing has been completed. COM should now be searchable via the community search engine now.

KellyF

graven
07-22-2003, 07:59 AM
seems to be working, now.
this fix has been overdue a long time. thanks a lot!

however, i still can't explicitly search for the term "COM+" (including the quotation marks).

the search engine simply cuts of the "+" and returns results for the search term "COM".

any ideas?

cheers, graven

TheGuru
07-22-2003, 08:46 AM
You've hit it on the head. There's a regex that removes non-word characters (/?\+-, etc. Because that's the default functionality, I am loath to modify it without knowing what sorts of things I'd be opening us up to. Whenever I've checked the board of the company that created the forum software, they've had pretty good reasons for doing things which I would've seen as unnecessary.

In this case, I'm going to have to just apologize for this apparent anomaly in the search functionality.

KellyF

PS. All is not lost for searching, though. :) I still hope to find a bit of time in the fourth quarter to hack the system to use fulltext indexing rather than this current mode.


Originally posted by graven
however, i still can't explicitly search for the term "COM+" (including the quotation marks).

the search engine simply cuts of the "+" and returns results for the search term "COM".

graven
07-26-2006, 11:11 AM
just tried to search the forum http://community.installshield.com/forumdisplay.php?f=192 for the term COM.

no results.
looks like the term COM is on the blacklist, again?

cheers, graven

RobertDickau
07-26-2006, 11:21 AM
I don't know about the community setup, but when the built-in search fails I visit the Support home page---

http://support.installshield.com

---select only "InstallShield Community" in the "Areas of Site" section, and search away. "COM" and "COM+" seem to work just fine.

Christopher Painter
07-26-2006, 11:39 AM
The server hosting vBulletin was probably restaged at some point in time. This probably resulted in the indexing list being set back to it's default.

Maybe someone can modify the list and rebuild the indices again?