View Full Version : Not finding V2.0 methods after install

06-20-2003, 05:26 PM
I've built my own customized interface into the update service. I installed the Update Service SDK on my notebook and used that for my testing during development and it worked great. Now that I have the interface completed, I've compiled my app and created an install on a different machine that also has the SDK. When I install the app on a 3rd, totally independent machine and try the update service, it fails on both the hasmessages or enumupdates calls, which indicates to me that maybe the old version (1.2) of the update service is getting installed rather than the new version (2.0). Anyone have any ideas on what I could look at to verify this, or what the problem may be?

FYI, even though my notebook still works for testing the update service, if I run the actual install of my app on the notebook, that update service fails as indicated above...???


Chris Woerner
06-23-2003, 10:06 AM
Be sure to install the SDK on the machine that is used to create/build your software installation. When the SDK is installed, it adds the latest runtime files to a location where our installer tools (Express, Developer and Professional) can find them.

06-23-2003, 01:16 PM
I know for sure that the SDK is on the machine that I use for my install builds. I even did a full reinstall (uninstall, clean out registry, reinstall) of the 2.0 SDK thinking that there was a version of the 1.2 SDK left on my machine somewhere. The thing that makes me think it is somehow picking up a 1.2 version is the fact that the isconnected method works fine everywhere, its just when I try to take the next step using the new 2.0 functionality things go south, but this is an assumption on my part.

I have a few things I want to try later today to see if they help at all, but in the meantime, if you have any other suggestions or tips, I appreciate any you can provide...

Chris Woerner
06-23-2003, 03:14 PM
One quick way to verify your assumption.... Look in the folder: C:\Program Files\Common Files\InstallShield\UpdateService

Right click on the Agent.exe and look at the version.

06-25-2003, 04:23 PM
I verified the version of agent.exe both on my build machine and on the target machine after the install and both indicate v2.0. I am pretty much out of ideas as to why the calls fail once I get past the isconnected call. Are there any other possible explanations for this, or things that I can try?

06-30-2003, 02:30 PM
You said, HasMessages() and EnumUpdates() failed. Can you explain, what is the error code you are getting.

I would like to distinguish whether it is an issue with
1) Problem with COM interface not getting registered or
2) Some other problem.

Moreover, HasMessages() existed in Version 1.2, where as EnumUpdates () is introduced in Version 2.0.

If we are looking at interface not getting installed problem here, please register agent.exe manually from command prompt as "agent.exe /RegServer". I understand this is not the solution but helps diagnose issue at hand.

Thanks for using InstallShield Update Service

07-03-2003, 01:10 PM
As with most issues like this, this is my own fault...the developer building the app used in the install had coded the wrong guid for the application, so it was using the wrong guid to check the update service, causing all the problems. Unfortunately, I haven't found a good way of capturing the error codes with the development tool I'm using, so I wasn't able to tell that this was in fact the situation. However, I have been able to code something into my custom update service window that will prevent this situation from reoccurring long before I get to the actual update service calls....

Thanks for your suggestions on this guys...