View Full Version : Non-admin check for updates

06-11-2003, 02:07 AM
I have a problem with checking for any updates while logged on as a non-admin user. I get error messages that states that I can't write to some database files and additionally the agent.exe crashes with an ugly error dialog.

I've read a few previous threads in this community and found that this is due to the fact that the update agent needs adminstrator privileges. All these threads are from last year though, and I installed a new version of the update service this spring. My urgent questions are:

1. Is this problem still not fixed ?

2. If not fixed, when will it be fixed ?

3. I've read that I could avoid the errors by changing the security settings on a few files. If this is correct, what files do I need to change and what are the new settings ?

This is quite urgent as we rely on all users at least getting a notification that a new release of our software is available.


Chris Woerner
06-11-2003, 10:35 AM
The Update Service uses files that are stored in the program files directory. So, non-admin users won't have rights those files. More information can be found in a KB article: Q107814


Another possible solution: Instead of putting the code that invokes the Update Service into your application, write a small service. Your application would invoke the service which can run at elevated privledges. This would allow the service to check for updates, download and even install the updates.

08-04-2004, 10:48 AM
Just checking, I'm evaluating v.3 of the service and want to know if this issue still exists on it.

Chris Woerner
08-04-2004, 11:23 AM
The Update Sercie no longer requires Admin Rights to run. However, your updates may or may not require admin rights to be properly installed. That isn't something the Update Service can avoid.

08-10-2004, 02:17 PM

this is incorrect. Update Service 3 has broken the earlier fix that you guys had put out which allowed non-admins users to run update-service enabled software.

i have a project (please check my thread from a few days ago, titled "update service 3 pretty much broken), which uses installshield X and update service 3. I require admin rights to install my software. However when a non-admin user logs in after the installation was done by an admin, windows installers starts up and gives an error that admin rights are need to install the software. bear in mind that the software is already isntalled.

upon looking in the event viewer, the complaint is about trying to write to the HKEY_CURRENT_USER\Software\InstallShield\UpdateService key, which doesnt exist. This wasnt a problem with the v2 update service (which used the "Update Service" key. note the space.

if you open the ISUS.ism merge module in installshield X , you will see a component called "DummyComponent" which wants to install this key. I deleted this component from the merge module, and saved it and rebuilt my installation. I still have the same problem.

Please help me if you can Chris. This is a wonderful product that you have, but some of the things you guys put in assume things which are erroneous. The fact is that most corporations do not give admin rights to regular users on their computers.

08-16-2004, 10:22 AM
Instead of removing the component, remove the registry item itself, located in the registry pane. This worked for me.

08-17-2004, 03:23 PM
Ignore my last post. Removing the registry item fixes your install but breaks the update service functionality. I called IS support; development is currently reviewing.

08-18-2004, 01:44 PM
The issue with me is that the "ISUSPM Startup" registry value is written into the registry (HKLM\Software\Microsoft\Windows\CurrentVersion\Run), with the data "C:\PROGRA~1\COMMON~1\INSTAL~1\UPDATE~1\ISUSPM.exe -startup"

When I log off and log on as a restricted user, the Windows Installer screen pops up, and (after cancelling several times) I get the message box "An error occurred. Error # -5", with a link to the consumer central Installshield website.

Now I can avoid this problem by removing that registry value, but then the updates don't run automatically at all.


Thanks in advance