PDA

View Full Version : Program Files directory causes error



kherman
06-03-2003, 01:47 PM
I am using InstallShield 5.0 multi-platform under unix. I am creating an installation project. A fairly simple one. I can create the executable. InstallShield creates the project without any problems.

My trouble comes when I try to install the program using the created files. Apparently, the install path is failing for some reason.

The desired path(default) is:
C:\Program Files\ABC\XYZ
I get the following error:
ERROR: C:\Program Files\ABC\XYZ is not writable

If I change the path to:
C:\Program_Files\ABC\XYZ
Everything works perfectly, however, our project requires that we use 'Program Files' without an underscore. When this succeeds, all missing directories are created without error.

Apparently the problem is that the installation program doesn't like it when I use spaces in the insallation path. How do I overcome this issue?

THANK YOU,
Karl

William
06-03-2003, 04:02 PM
Hace you tried using "C:\Program Files2\ABC\XYZ" as the installation directory??? If that works, then it is not the space that is causing the problem and my question would be whether or not you have write access to the directory in question.

kherman
06-04-2003, 06:32 AM
I tried putting quotes around everything and the operation still failed.

As for the comment on:
"... my question would be whether or not you have write access to the directory in question."

I think this might be it. I'll be checking this out this morning. Yesterday, I tried the following and it worked:
C:\'Program Files'\ABC\XYZ
Single quotes were put around Program Files. The installer ran as expected. So I think your assumption that I don't have write permissions for the Program Files directory may be correct.