PDA

View Full Version : cannot open project



mtelafici
05-22-2003, 03:51 PM
Has anyone seen this or something similar, when trying to open a project:

An error occurred parsing the project(com.jxml.quick.QPE: unrecognized tag: built)

The file hadn't been changed since I had successfully opened the project and build an .exe for a coworker. The xml file in question shows up when I open it in a browser, so I assume the xml is fine...

Houwei
05-22-2003, 04:14 PM
changing or deleting your custom bean may cause problem.

William
05-22-2003, 04:17 PM
Could you post the problematic project file?

Also, was the project originally created with ISMP 5.0 or with an earlier version?

mtelafici
05-22-2003, 04:23 PM
It was created in ISMP4.5. I've attached the file:

William
05-22-2003, 04:51 PM
Have you been manipulating the project file manually??? YOu have a rogue "property" (for some "defaultValue" property) XML tag in between the two wizard beans with id's of "InstallPath" and "GetJavaHome" in the wizard tree. That is what's causing the parsing problem. As soon as I removed that "property" line, the problem went away.

mtelafici
05-22-2003, 05:03 PM
Thanks William; I just went through the file again and caught it. I deleted it and I'm back in business. Damn those rogue properties...;)

abansal
11-06-2003, 02:05 AM
Hi Williams,

I am also getting into the same problem, I am usng ISMP 5.0 sp 2, File that I created at my machine, gives following error “A error occurred parsing the project. (com.jxml.quick.QPE: unrecognized tag: visible)”

Could you help me in the same. And also using what you validate the file and how can we also validate files that they are in order. I haven't done any changes manually.

Also if the file is created at other machine, then I am able to open the same at my machine

Regards,

Anil

William
11-06-2003, 10:56 AM
I just downloaded the project file and had no trouble at all opening it with ISMP 5.0 SP2. Is this really the project file that you saw causing the problem?? I noticed the "[1]" at the end of the project file name... are you sure it's not (1) an altered copy of the problem project or (2) the result of a conversion of an older project?

abansal
11-10-2003, 03:56 AM
Hi Williams,

Thanks, I checked my file again, and found that visible property has crept in under the product properties, and that property is not listed there. So after removing it started working properly.

What I observed that with ISMP 5.0, same file wouldn't work, but with ISMP sp2, it will work. So to make it work with ISMP 5.0 we need to rmove that property at line 91 of the file.

ALso do you have any dtd/schema, against which you validate product.xml, because that would be helpful to everybody, and not do line by line check of rogue properties.

Thanks once again.

Anil Bansal