PDA

View Full Version : Custom Bean not loading at runtime



ozer_richard
05-06-2003, 03:04 PM
I have installed MP5, Eval Version 5.00 B278. I am working through Chapter 5, Customization (i.e. Custom Beans).

I created FirstWizAction verbatim from the manual and have successfully registered the class with the Bean Gallery. I Inserted FirstWizBean right after my Welcome Panel and it compiled with no errors.

When I run my application, the FirstWizAction panel does not
show up, and the log file has the following:

(06-May-03 3:29:31 PM), Install.product.install, com.installshield.wizard.StandardWizardListener, wrn, could not initialize interface swing - trying awt

(06-May-03 3:29:33 PM), Install.product.install, com.installshield.wizard.awt.AWTWizardUI, wrn, skipping bean Wizard Bean Place Holder (InstallFirstWizAction) because it could not be loaded

-------------------------

Question: Is this a JVM version issue? I noticed that the first
page of the "InstallShield MultiPlatform User's Guide" warns about
the on-line User's Guide not working right with JVM 1.4.0_02.

Question: If it is the JVM, how do I switch ISMP from using its bundled JVM, 1.4.0_02, to using my system's installed JVM, 1.4.1_02?

Under System Info, my JVM info is:
Vendor Sun Microsystems Inc.
VendorWebsite http://java.sun.com/
JVMVersion 1.4.0_02
Java API Version 48.0
JavaDirectory C:\Program Files\InstallShield\MP50Eval\_jvm
TempDirectory C:\DOCUME~1\rozer\LOCALS~1\Temp\
JavaClassPath
_C:\Program Files\InstallShield\MP50Eval/ppk/aixppk.jar
C:\ProgramFiles\InstallShield\MP50Eval/ppk/cimppk.jar
C:\ProgramFiles\InstallShield\MP50Eval/ppk/genericunixppk.jar
C:\ProgramFiles\InstallShield\MP50Eval/ppk/hpuxppk.jar
C:\ProgramFiles\InstallShield\MP50Eval/ppk/linuxppk.jar
C:\ProgramFiles\InstallShield\MP50Eval/ppk/macosxppk.jar
C:\ProgramFiles\InstallShield\MP50Eval/ppk/as400ppk.jar
C:\ProgramFiles\InstallShield\MP50Eval/ppk/solarisppk.jar
C:\ProgramFiles\InstallShield\MP50Eval/ppk/webppk.jar
C:\ProgramFiles\InstallShield\MP50Eval/ppk/win32ppk.jar
C:\Program Files\InstallShield\MP50Eval/classes
C:\Program Files\InstallShield\MP50Eval/i18n
C:\Program Files\InstallShield\MP50Eval/lib/ide.jar
C:\Program Files\InstallShield\MP50Eval/lib/wizard.jar
C:\Program Files\InstallShield\MP50Eval/lib/parser.jar
C:\Program Files\InstallShield\MP50Eval/lib/swing.jar
C:\ProgramFiles\InstallShield\MP50Eval/lib/icebrowserlitebean.jar
C:\Program Files\InstallShield\MP50Eval/lib/help.jar
C:\Program Files\InstallShield\MP50Eval/lib/jhall.jar
C:\Program Files\InstallShield\MP50Eval/lib/product.jar
C:\ProgramFiles\InstallShield\MP50Eval/lib/icebrowserbean.jar
C:\Program Files\InstallShield\MP50Eval/lib/xt.jar
C:\ProgramFiles\InstallShield\MP50Eval/lib/platform.jar
C:\ProgramFiles\InstallShield\MP50Eval/lib/beanhelpupdates.jar
C:\Program Files\InstallShield\MP50Eval

mattymcg88
08-29-2003, 08:17 AM
Has anyone found a possible cause for this error? I am getting the same error with a custom wizard bean in one of my projects. I created a project with ISMP 5.0 SP1 and the bean works great. I then upgraded to ISMP 5.0 SP2 and the bean still works. Then I created a new project which required the exact same bean, and when I run the installer the bean does not execute and the log file says:

Setup.product.install, com.installshield.wizard.swing.SwingWizardUI, wrn, skipping bean Wizard Bean Place Holder (bean name) because it could not be loaded

There is absolutely no difference between the bean in the working project and the bean in the unworking project. Both projects are using the same JVM and I can't find any other settings that might fix the problem. Any ideas?

evgenyp
12-18-2003, 04:27 AM
I got the same
Anyone? What is the cause??

r.elberger
12-26-2003, 01:00 PM
Is this a wizard action or a wizard panel?

I don't think wizard actions should be trying to resolve UI implementors...

Also, posting the code as attachment would help.

-- rich

DME170
03-23-2004, 06:07 PM
I'm getting this now too.

The custom bean its complaining about used to be working fine. I went in and made some changes to it - now I keep getting this "skipping bean Wizard Bean Place Holder (CustomBean) becuase it could not be loaded.":(

Anyone from InstallShield have any ideas?