PDA

View Full Version : MultiPlatform 4.53 vs 5.0



Mike Snodgrass
04-16-2003, 10:34 AM
I'm new to the world of Multiplatform, but have a good base of MSI install development skills.

I am working with an installation package that I recently acquired. The install is to be run from a Windows environment and install libraries on an AS/400. The install worked fine with MultiPlatform 4.53, however, upon migration to 5.0, I am seeing problems.

I've forced the install to create a log, by executing from the command line:
setup.exe -is:log c:\myLogFile.txt

I've been able to log msi installs and gather great information from the logs. However, I'm not sure how to read the following data in this log file. Any assistance in reading the log files is greatly appreciated!


Here's a snippet of my log file:

------------------
file type: 0
file id: 0
length: 77
offset: 299090
file name: instructions.txt
file type: 7
file id: 1
length: 6725215
offset: 299167
file name: setupwin32.exe
------------------
file type: 0
file id: 0
length: 187
offset: 299090
file name: instructions.txt
file type: 5
file id: 1
length: 1009
offset: 299277
file name: Verify.jar
file type: 2
file id: 2
length: 746
offset: 300286
file name: launch.txt
file type: 4
file id: 3
length: 6424038
offset: 301032
file name: Windows-Sun-1.3.1_06.exe
Executing launch script command: "C:\DOCUME~1\msnodgra\LOCALS~1\Temp\LRE9.tmp/bin\java.exe" -cp "";"C:\DOCUME~1\msnodgra\LOCALS~1\Temp\LREA.tmp\setup.jar";"" -Dtemp.dir="C:\DOCUME~1\msnodgra\LOCALS~1\Temp" -Dis.jvm.home="C:\DOCUME~1\msnodgra\LOCALS~1\Temp\LRE9.tmp" -Dis.jvm.temp="1" -Dis.media.home="D:/setup" -Dis.launcher.file="C:\DOCUME~1\msnodgra\LOCALS~1\Temp\LRE8.tmp\setupwin32.exe" -Dis.jvm.file="C:\DOCUME~1\msnodgra\LOCALS~1\Temp\LRE9.tmp\jvm" -Dis.external.home="D:" -Xms20m -Xmx60m run in working directory C:\DOCUME~1\msnodgra\LOCALS~1\Temp\LRE8.tmp
Output from the launch script execution
StdOut:
(Apr 16, 2003 8:00:53 AM), Setup.product.install, com.installshield.wizard.platform.win32.Win32PPKRegistryServiceImpl, dbg.registry, reading VPD from C:\WINNT\vpd.properties

(Apr 16, 2003 8:01:01 AM), Setup.product.install, com.installshield.wizard.platform.win32.Win32PPKRegistryServiceImpl, dbg.registry, writing VPD to C:\WINNT\vpd.properties

(Apr 16, 2003 8:01:05 AM), Setup.product.install, com.installshield.wizardx.conditions.StringComparisonWizardBeanCondition, err, resolve string comparison: Syntax error at pos#1

(Apr 16, 2003 8:01:05 AM), Setup.product.install, com.installshield.wizardx.conditions.StringComparisonWizardBeanCondition, err, resolve string comparison: Syntax error at pos#1

(Apr 16, 2003 8:01:05 AM), Setup.product.install, com.installshield.wizardx.conditions.StringComparisonWizardBeanCondition, err, resolve string comparison: Syntax error at pos#1

(Apr 16, 2003 8:01:05 AM), Setup.product.install, com.installshield.wizardx.conditions.StringComparisonWizardBeanCondition, err, resolve string comparison: Syntax error at pos#1

(Apr 16, 2003 8:01:05 AM), Setup.product.install, com.installshield.wizardx.conditions.StringComparisonWizardBeanCondition, err, resolve string comparison: Syntax error at pos#1

(Apr 16, 2003 8:01:05 AM), Setup.product.install, com.installshield.wizardx.conditions.StringComparisonWizardBeanCondition, err, resolve string comparison: Syntax error at pos#1

(Apr 16, 2003 8:01:05 AM), Setup.product.install, com.installshield.wizardx.conditions.StringComparisonWizardBeanCondition, err, resolve string comparison: Syntax error at pos#1

(Apr 16, 2003 8:01:05 AM), Setup.product.install, com.installshield.wizardx.conditions.StringComparisonWizardBeanCondition, err, resolve string comparison: Syntax error at pos#1

(Apr 16, 2003 8:01:05 AM), Setup.product.install, com.installshield.wizardx.conditions.StringComparisonWizardBeanCondition, err, resolve string comparison: Syntax error at pos#1

(Apr 16, 2003 8:01:05 AM), Setup.product.install, com.installshield.wizardx.conditions.StringComparisonWizardBeanCondition, err, resolve string comparison: Syntax error at pos#1

(Apr 16, 2003 8:01:05 AM), Setup.product.install, com.installshield.wizardx.conditions.StringComparisonWizardBeanCondition, err, resolve string comparison: Syntax error at pos#1

(Apr 16, 2003 8:01:05 AM), Setup.product.install, com.installshield.wizardx.conditions.StringComparisonWizardBeanCondition, err, resolve string comparison: Syntax error at pos#1

(Apr 16, 2003 8:01:43 AM), Setup.product.install, com.ibm.wizard.platform.as400.as400Command, err, CPF2110 Library JDA4R6INT not found.

(Apr 16, 2003 8:01:43 AM), Setup.product.install, com.ibm.wizard.platform.as400.as400Command, err, CPF2110 Library MMDEXLIB not found.

(Apr 16, 2003 8:01:43 AM), Setup.product.install, com.ibm.wizard.platform.as400.as400Command, err, CPD0013 A matching parenthesis not found.

(Apr 16, 2003 8:01:43 AM), Setup.product.install, com.ibm.wizard.platform.as400.as400Command, err, CPF0006 Errors occurred in command.

(Apr 16, 2003 8:01:43 AM), Setup.product.install, com.ibm.wizard.platform.as400.as400Command, err, CPF2110 Library PASSINT not found.

William
04-18-2003, 01:33 PM
To use an install that installs to a remote AS/400 machine, it is necessary to run the installation with the "-os400" command-line parameter.

NOTE: This was also the case in 4.5. The fact that it may be "working" based upon what you've seen as the end result, does not mean that it was properly working. It would simply have meant that the particular scenario you were wokring with did not trigger apparent problems. The proper way to run a remote AS/400 installation is to run with the "-os400" command-line property.