PDA

View Full Version : Can't install on OS/400?



jianghao
04-10-2003, 05:40 AM
Error message:

WARNING: could not write using log service: ServiceException: (error code = 2
00; severity = 0; exception = [java.lang.NullPointerException])
(Apr 10, 2003 6:11:27 PM), Install.product.install, com.installshield.product
.wizardbeans.DestinationPanel, wrn, null
Error: /home/ismptest is not writable.
-----------------------------------------------------------------------------
--
ISMP Install Location
Please specify a directory or press Enter to accept the default directory.
Directory Name: [/home/ismptest ]


Procedure:

I try to generate an installer for OS/400. It's a very simple package which just generate from ISMP 5's "Typical Product" wizard, besides a few files, nothing changed. I follow the build instruction for OS/400 , and a installer package is ok now. I burn the four files(media.inf, QTEMP, QTEMP2, SETUP.JAR) into root folder of CD-R, run "LODRUN OPT01" with account "QSECOFR".
InstallShield is running now, and give me lots of prompt, just like it on other unix platforms. Finally when I want to set the installation directory, I have the trouble.

Other information:
I use account "QSECOFR", system is V5R1.
I confirmed that /home/ismptest directory exists and disk is not full.
I didn't change the QINSTAPP2 source. TARGET RELEASE is *CURRENT
It seems that there are 5 Java related package installed in OS/400 system, SUN JDK 1.1.8. 1.2, 1.3 and two "Java Development Kit"




What should I do to make this installer continue?
Thanks for your help!

DME170
04-10-2003, 08:45 AM
My only guess is that your QSECOFR user profile does not have authority to the directory. Try specifying a different directory for the install to see if that works. Also - examine the authorities for the directory /home/ismptest.

Bergen
05-22-2003, 03:41 AM
I get the same error during installation on Linux.
A message pop's up saying the directory is not writable when I press the NEXT button on the destination panel. The thing is if I just press OK to the message and press NEXT again, everything is fine, the installation continues!

So it seems like all the permissions are okay. I also got the same error in 4.53.

The problem does not occur on Windows.

Anybody has any ideas on how to solve this?
Thanks.

Bergen
05-23-2003, 04:32 AM
Looks like my problem was caused by a space in the install path. This bug should be fixed in SP 1. I will update and try again.

(wonder why it's not fixed for AIX...)

From Q107975:
If a path containing spaces is selected in the Destination Panel on unix systems, an error is displayed indicating that the destination path is not writable.

This has been fixed in 5.0 Service Pack 1. The Destination Panel now allows spaces in the destination path on all platforms except AIX.