PDA

View Full Version : Win32 Registry Update



Pascal_Jouve
03-20-2003, 03:58 AM
Hello,

Firstly I'm sorry for my english writing, I hope you will understand me.

I'm trying to build a package for Windows NT 4 and Windows 2000 targets of a product.
All works fine except "Win32 Registry Update" bean : the ".reg" update file is ignored by installation on all targets.

Following the properties of the "Win32 Registry Update" bean that I defined inside my project :

Win32 Registry Update
- bean ID : bean8
- Active : True
- Registry File : D:/WINCONF/WinConf.reg

and D:/WINCONF/WinConf.reg content simply is :

----------------------------------------------------------------------------------------------------------------------------------------------------
REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\My_Company]
[HKEY_LOCAL_MACHINE\SOFTWARE\My_Company\WinConf]
[HKEY_LOCAL_MACHINE\SOFTWARE\My_Company\WinConf\V400]
----------------------------------------------------------------------------------------------------------------------------------------------------

Is there something wrong ?

Thanks.
Regards

Jeff Dillon
03-20-2003, 03:07 PM
Your registry file does not actually set any variables. What are you expecting it to do?

Here is an example reg file to set the value MyProperty...

REGEDIT4

[HKEY_LOCAL_MACHINE\Software\MyCompany]
[HKEY_LOCAL_MACHINE\Software\MyCompany\MyProduct]
"MyProperty"="$P(absoluteInstallLocation)"

Pascal_Jouve
03-21-2003, 02:47 AM
I'm using an evaluation version of InstallShield Multiplatform 5.00, in order to recommand it to my company (if it works).

Targets will be Windows NT 4, Windows 2000, Solaris, AIX, Linux.

I try to test all main fonctions and the simpliest Windows registry update does not work. All registry update is ignored.

The following ".reg" file does not work within InstallShield ("Win32 Registry Update" bean), but works with regedit command (except variable resolution).

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\My_Company]
[HKEY_LOCAL_MACHINE\SOFTWARE\My_Company\WinConf]
"InstallDir"="$P(absoluteInstallLocation)"


Someting should be missing in my project : Wizzard, component...???

I can't understand.

Thank you for your help.

Jeff Dillon
03-21-2003, 09:56 AM
Make sure that your .reg file is encoded an a simple ascii text file.

Unicode encoded files do not work.

To make sure, you can open the .reg file in Wordpad and save it as a text file. (Not Unicode file.)

Pascal_Jouve
03-24-2003, 03:17 AM
It works now !
Thank you for your help.

The first two characters of my ".reg" file were "FF FE" despite Notepad and Wordpad editing. May be caused by a previous Ultraedit edit session.

I created a new ".reg" file whith Notepad from scratch, rebuilt the package, and it works.

Thank you.
Regards.

tim.wall
03-24-2003, 04:35 PM
Only ASCII files will work? I find exactly the opposite: if the .reg is saved as ASCII, I get errors on installation.

sextant
03-25-2003, 10:07 AM
I also have problems registrying a .reg file.
My file was exported from the registry, edited snd installed again using Install Shield.
I have tried it with Unicode and ascii and it will not take either.
Any advice much apreciated.

Thanks
Adrian Hyde

Reg file lookes like :-

REGEDIT4

[HKEY_CURRENT_USER\Adrian]
"Name"="Adrian"

sextant
03-25-2003, 10:52 AM
OK Sorted it,
There seemed to be a problem with the registry. When an old key was deleted, the new one went in a treet!

Adrian

knightspace
04-22-2003, 01:32 PM
Any idea why I can't create a registry entry when I use a space in the company name. It's works when I change the space to a dash, here's my reg file:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\My Company]
"HOME"="$P(absoluteInstallLocation)"
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

If I just run the reg file it goes into the registry, but not through InstallShield

:confused:
Rob

Is the answer to this anywhere else? If it is I haven't found it yet.