PDA

View Full Version : vBuild and Update Service



zetron
03-07-2003, 04:03 PM
How can the vBuild OCI setup be integrated with InstallShield's Update Service? I am using InstallShield Professional 7.0 SP 1 to create my setups. Thanks.

IlanaB
03-07-2003, 05:36 PM
Hi Edmond,

The vBuild Online package created from an IS Pro 7.01 OCI setup can be posted on the Update Service in exactly the same way you would post a non-vBuild OCI setup - just point to the setup.exe of the package in the Download URL definition of your Update Service message. There is no additional integration involved.


Ilana Bogomolny
ilana@redbend.com

zetron
03-07-2003, 07:23 PM
I tried to link to setup.exe located inside the OCI folder, and when I clicked Install from Update Service web, the setup.exe was downloaded but nothing happened next. I selected "InstallShield Professional 7, One-Click Install" as the package type when I defined the message in Update Service.

I also ran PackageForTheWeb on the OCI media to get a single exe. This time the installer could be launched, but instead of downloading the differences, it downloaded the entire exe file.

IlanaB
03-08-2003, 04:38 AM
After the setup.exe of IS Pro 7.x OCI setup is downloaded by the Update Service, it takes some time until the installation actually executes, because Update Service also needs to download a few additional files, such as data1.hdr, data1.cab etc. before it can start. It's exactly the same process with a vBuild Online package you create from the OCI setup - the initial download part is pure Install Shield. But once the few necessary files are downloaded, the installation will start an proceed as you have designed it, downloading only the necessary components and updates.

When you package everything into a single self-extracting executable, there is no way to download parts of the installation - everything is brought together in one big chunk. And because when the setup.exe starts running all the content and installation files are already there, there is no delay. But of course, you need to wait much longer for the setup.exe to download.



Ilana Bogomolny
ilana@redbend.com

zetron
03-08-2003, 12:56 PM
The launching of the setup did not occur, and the update status on the web page changed to "Your update is Complete. You can close this window and return to your application or you can view more update for this product."

IlanaB
03-09-2003, 04:11 AM
This must have something to do with the way you have integrated your application with the Update Service. You should get an answer on the Upate Service community - I saw you have posted the same question there. In any case, vBuild has no part in the US integration - vBuild Online package behaves exactly as the OCI setup you have imported as the target version.

Ilana Bogomolny
ilana@redbend.com

IlanaB
03-11-2003, 12:01 PM
Edmond,

I was happy to see that the problem you reported here was solved by changing the URL link format of the Setup.exe file.

To complete the picture for anybody browsing this thread, see ISPro 7.01 OCI + ISUS (http://community.installshield.com/showthread.php?s=&threadid=112490) on the Update Service community for more details.

Ilana