PDA

View Full Version : 2 Problems with redistributables



OverKill
01-29-2003, 01:03 PM
2 problems I have just run into after sending many CD's to clients:

1 - DAO350.dll for some reason is getting installed to the [installdir] instead of to the common files folder, while this allows the software to still work, if I uninstall the software, it removes that dll and unregisters it. This results in the file still existing in the common files folder but no longer register, and any other program that needs this file no longer runs.

2 - When scanning my project, installshield didn't add Jet351 even though the project requires it.

Paul M.
01-30-2003, 10:03 AM
I would suggest looking at the Files view and verifying where DAO350.dll is in that view. Most likely it is in the folder marked as [INSTALLDIR] and if you want it to install to the CommonFiles Folder you would need to put it in that folder in this view. Also, if you want this to be left behind you would need to make it either permanent or shared. You can do this by right clicking on the file and choosing properties and going to the Advanced tab.

OverKill
01-30-2003, 10:43 AM
But in the old version (3.53), DAO350.dll was installed to the common files folder. Why its different now, I have no idea. But the problem isn't with my app, but with all of the other apps on a clients machine that needs DAO350.dll. If I let installshield install the file to the [installdir], and then uninstall my app, all of the other programs that need the file stops working. Not very good at all. But if I change the folder to the common files, when installshield installs my app, it checks and finds the file, and increments that this DLL now has another app that uses it. When I uninstall, it decrements this number. This is the way it was suppose to run and how it use to run in 3.53.

Paul M.
01-30-2003, 11:36 AM
It still works the same way. MSI is what handles this functionality and MSI has not changed from version 3.53 and 3.54. As I suggested make sure the DAO350.dll is marked as shared and this will behave the way you would like it to.

OverKill
01-30-2003, 01:47 PM
I hate to tell you paulmerritt, but it did work in 3.53, I can load any of my old projects and see that DAO350 in the scanned project is set to the common folder.

But regardless, the easiest way to fix the problem was just to remove it from the scanned project and add it manually to the right position and now it works exactly the way it did in version 3.53.

Hopefully there will be an upcoming patch that solves these and the other problems soon.