PDA

View Full Version : Express 4.0 won't work with Windows 2003 Server



Dactyl
01-24-2003, 11:54 AM
Without thinking about it too much, since I've been using Windows 2003 server as my development platform for some time now, I installed InstallShield Express 4.0 on it shortly after upgrading to 4.0. Everything in the install processes normally, but when I try to run Express, the splash screen appears momentarily, then the program just stops running without an error.

I checked the install folder, and noticed a iside.log file, which contains this:

D:\BldRoot\source\src\iside\iside.cpp 844: ActiveX component can't create object
> ISApp.CApp.StartApp
> ISApp.CApp.IApp_Start

Any idea what is causing this problem or how I can work around it?

Neeru
01-24-2003, 02:19 PM
Hello,

Try registering the file scrrun.dll on your machine to see if that fixes the issue.

To register scrrun.dll, use the following command line:
regsvr32 "<path>\scrrun.dll"

The file scrrun.dll should be in the system directory of the machine.

Thanks
Neeru

Dactyl
01-24-2003, 06:02 PM
I tried that, and got a "scrrun.dll has been registered sucessfully" message, but it didn't change the way Express works. I've used the scripting runtime in other applications on this machine, so I know it is registered correctly.

Chandima
01-27-2003, 01:24 PM
Run the express executbale with the following command line and post the log it generates here:

iside.exe /verbose

Dactyl
01-27-2003, 01:33 PM
Here is the contents of the iside.verbose file generated after I did that:

Initializing OLE libraries...
Enabling control container...
Perform product activation...
Enabling 3d controls...
Registering document templates...
Allocating splash screen...
Creating ini file reader...
Determining path to iside.ini...
Loading iside.ini...
Parsing iside.ini...
Creating UIServices object...
Getting iside registry path...
Loading the reosurce DLL...
Setting the reosurce handle...
Showing splash screen...
Initializing document...
Check Digital Wizard Update Service for Internet connection...
Setting application frame...

Chandima
01-28-2003, 04:01 PM
Use the attached tool to re-register all your files and let me know if that fixes the issues.

Dactyl
01-28-2003, 04:36 PM
I selected all the files on the COM tester page, and selected to have it Register Selected. I attached the results as copied to the clipboard.

Chandima
01-30-2003, 12:37 PM
Sorry for the late follow up, but did re-registering everything using the tool fix your problem?

Dactyl
01-30-2003, 12:54 PM
Nope, still getting the same error. As the results showed, even after "re-registering" everything, some files on the system were not registered.

eraser465
04-21-2003, 10:44 PM
I'm having the same problem with Windows Server 2003 and Visual Studio 2003. I tried upgrading an existing VS 2002 project which had an IS project and the VS environment crashed while loading Installshield. Removed the IS project and solution loaded. Tried adding a new IS project to solution, firstly the IS Wizard complains about a component not being found and when I try the IS project, the IDE crashes on me. Tried running IS outside the VS environment and I get the same problem as per this thread.

Chandima
04-22-2003, 09:26 AM
We looked in to this and it is a known issue. This has been fixed in the Express 4.0 Service Pack. Please use the Update Service (InstallShield Express) to get the Service Pack. Thanks!

eraser465
04-22-2003, 02:55 PM
Would love to get my hands on SP1 however seen as that IS beta is not working, I cannot get into the update server option. Any ideas on how to get the SP ?

Chandima
04-22-2003, 02:57 PM
Please email me at chandimar@installshield.com and I will send you a link. Thanks!