View Full Version : Cannot Launch Express from Program Icon

01-17-2003, 08:56 AM
Good morning,

I have been having a problem since I installed ISX4 (actually, since the first time I CLOSED ISX4).

The problem is that when I try to open Express using my Start | Programs | Installshield | Express link that was created when I installed Express, the splash screen comes up for a moment and then nothing happens. After about a minute, the splash screen goes away and there is no activity.

There are no application event errors and there does not appear to be any running program in the task manager.

If I double click on the project I setup the first time I launched Express (when the installer launched it for me),
the splash screen stays up for about twice as long and then I can get into Express and do whatever I need to do.

I am running Windows 2000 Server with all service packs and the version in the Express about box is simply 4.0.

Any suggestions?

01-17-2003, 12:04 PM
Do you have Norton or McAffee running? If so does it make any difference if you turn them off and try running Express?

Launch the Express executable from the command line with the following parameters:

Iside.exe /verbose

This will create a file called "iside.verbose". Please post the contents of this file here. Thanks!

01-17-2003, 12:06 PM

OK. I will do what you suggest and come back with the results.

We use ETrust Antivirus. I have not tried disabling it but I will do that, too.

I'll get back to you in a short while.


01-17-2003, 12:32 PM
Chandima, Here are the results of what you requested.

Disabling the Anti-virus software had no effect. The program icon still did not work.

However, when I went and ran from the command line, Express DID launch successfully. Here are the contents of the file.

****** begin file *****

Initializing OLE libraries...
Enabling control container...
Perform product activation...
Enabling 3d controls...
Registering document templates...
Allocating splash screen...
Creating ini file reader...
Determining path to iside.ini...
Loading iside.ini...
Parsing iside.ini...
Creating UIServices object...
Getting iside registry path...
Loading the reosurce DLL...
Setting the reosurce handle...
Showing splash screen...
Initializing document...
Check Digital Wizard Update Service for Internet connection...
Setting application frame...
Opening initial project...
Destroying splash window...
Initializing Serial Number Validation...
Showing main window...
Get Product Code from AppSettings...
Check Digital Wizard Update Service for Scheduled Messages...
Perform Live Page Download...

*****end of file ****

I wonder -- I just went to the properties of the shortcut for the program and it says the target is "Installshield Express" instead of an application file name. So, that would lead me to believe that perhaps I have a corrupt registry setting? No idea what to look for, though.

Let me know what you suggest.


01-17-2003, 12:44 PM
I'll pass this info along to development. The shortcut has those properties because it's an "Advertised shortcut" instead of a normal one.

1. Does manually running the exe directly work?
2. If so, does manually creating a shortcut to it work?

I'll get back to you when I here from Development. Thanks!

01-17-2003, 01:09 PM


If I run the command line that you gave me, iside.exe /verbose, it works.

if I double click on iside.exe in Windows Explorer, it does not launch (splash screen, then nothing else).

I created a shortcut with this target:

"C:\Program Files\InstallShield\Express\iside.exe"

and it does not launch.

I made the shortcut include the /verbose switch and it launches.

Thanks for your help! Let me know what you find out.


01-17-2003, 04:07 PM
Development said that it probably has something to do with the Update Service. Once you launch Express:

1. On main menu go to Tools->Options->InstallShield Updates
2. Set the value of the first combo box to "Never"
3. Close Express
4. Try launching through the normal Express shortcut

Does this work?

01-17-2003, 04:12 PM
Nope. The only difference after doing what you suggested is that it closes the splash screen faster (it is open for about 2 seconds now instead of about 10).