PDA

View Full Version : BDE Merge Failure



lynnmorrison
12-18-2002, 10:52 PM
Hi all, I am new to this list and did not see an answer to this, so I'll throw it out there for you all...

I have created a project that uses the BDE Merge module that compiles just fine, but when I go to test the install, I get an error say "BDE Merge failed, use BDE administrator to merge the file" or something to that effect.

I configured the BDE merge module to use a new INI file and put one alias into that configuration. I already have an alias defined in that name so I am wondering if this is only a 'collision' of sorts? Maybe it doesn't want to overwrite existing settings for that alias?
Am I way off base or am I onto something here?

Anyhoo, any help would be greatly appreciated..

thanks,

Lynn Morrison

Paul M.
12-26-2002, 11:34 AM
Does this problem occur everytime you build a setup and include BDE in it? If so I believe that it maybe a bug with the Express 4.0. Please verify this and let me know

lynnmorrison
12-26-2002, 05:41 PM
Originally posted by paulmerritt
Does this problem occur everytime you build a setup and include BDE in it? If so I believe that it maybe a bug with the Express 4.0. Please verify this and let me know

Just to test the theory, I created a new application project with absolutely nothing in it except a table and an alias. Then I created a new IS, told it to use a new cfg file, added the alias to it and compiled it. The compile ran just fine but at the end of the 'test installation' I got the same error.... I then went to a couple of other existing projects and also got the same result...

So, in short, yes, all setups are doing the same thing. I am now going to try to reinstall my merge module to see if that helps...

Thank you so much for your response...

Paul M.
12-27-2002, 08:11 AM
This is what I believe is happening. In the msi package that is built there are several things that are needed for the BDE merge module to run correctly, one of these things is BDEMMHelper.dll. In Express this dll is not being added to the project correctly. It has been made aware to Development and the work around is to open your MSI with Orca. Once your MSI is open browse to the Binary table. In this table you will want to add a new row called BDEMMHelper.dll and for the data browse to [ProgramFilesFolder]InstallShield\Express\Support\BDEMMHelper.dll and then save the MSI. If you then run this MSI the installation should run fine.

lynnmorrison
12-28-2002, 11:07 AM
Thanks for the response, however I do not have this program ORCA. I will look for it on the web and try what you have suggested...

Thank you...

lynnmorrison
12-28-2002, 11:37 AM
Ok, further to this, and I think this might be the problem...

I tried to uninstall the merge module to reinstall it. Now I cannot even reinstall it as it says I have no valid version of Builder or Delphi. I know this to be incorrect, but it unfortunately does not help...

Perhaps I have now stepped backwards, I am not sure, but I think I had better resolve this issue before I get deeper into the configuration...

P.S. - I am not impressed with these merge modules so far...:confused:

lynnmorrison
12-28-2002, 03:54 PM
ok, I had to reinstall Builder so that the merge module sees it as a valid install. Now it all looks good, the merge module is indeed back in IS under redistributables and can be configured...

Now I do not get the merge failure, but the merge is also not successful. Along with this, many files are missing (borlndmt.dll etc) from the install on the target system.

For that matter, sub dirs I make in the install with files in them are also not copied to the target system...

Any ideas or should I start a new thread?

Paul M.
12-30-2002, 08:14 AM
It would seem as if you are experiencing a new problem. I would recommend starting a new thread for this matter.

Mike Marino
01-02-2003, 12:30 PM
Can you tell me what color the icon in front of the BDE Merge Module is in the Redistributables View is? If it is red, the problem is that InstallShield Express is missing some registry data to correctly add BDE to your project.

If this is the problem, please let me know so I can send you a .reg file to correct the problem.

lynnmorrison
01-02-2003, 04:06 PM
Its a teal color and it looks like a cube...

Thanks for the response!

Mike Marino
01-02-2003, 04:38 PM
Try the suggestion from an earlier post about using orca. You can obtain Orca from:

http://www.microsoft.com/msdownload/platformsdk/sdkupdate/default.htm?p=/msdownload/platformsdk/sdkupdate/psdkredist.htm

You have to download the Windows Installer 2.0 SDK....Orca is part of that.

Hope this helps

lynnmorrison
01-02-2003, 05:24 PM
Ok, I am trying to do the suggested fixes, but I do not have an MSI file, the only one related to BDE Merge Module is an MSM file?

Is that what Paul meant or do I have to edit 'each' install I make to change the msi file?

Wouldn' t it be easier to just edit the MSM file and then all installs will work?


Thanks!

lynnmorrison
01-02-2003, 05:48 PM
further to this...

When I go into the installs MSI file, the helper file is already there!

mind you it is setup to go into something called [Binar Data]

does this help at all?

Thanks

lynnmorrison
01-02-2003, 06:13 PM
Ok, did everything you asked to the compiled MSI file and still the same problem.... the alias is defined but there is no path to it in the BDE administrator...

This is frustrating... just to get a lousy 'simple' install has become a nightmare.... at least with 2.13, I was up and running in minutes... please tell me that version 4 ISE is a beta... :)

thanks once again....

Mike Marino
01-03-2003, 10:40 AM
I had you check for BDEMMHelper.dll in the binary table to make sure that InstallShield Express was including all of the required components for the BDE Merge Module.

Borland supplies us with that Merge Module, so since this appears to be an internal error to the Merge Module, you may want to check with Borland's support to see if they have heard of this error, or know what causes it.

I do not have any of their source code for this Merge Module, otherwise I would attempt to find that error.

I will attempt to see if our contact at Borland has heard of this issue...but it may be faster for you (a Borland customer) to contact them directly.