PDA

View Full Version : Internal Error 2211.quickpatch_generated



pushparaj
12-08-2002, 02:09 PM
I am evaluating InstallShield Express 4.0. I have created setup for one of my products. It installed correctly in my machine and test machines.

Then I created a QuickPatch with updated files (Version upgraded). When I ran the Update.exe it worked fine in my machine (Windows 2000 Pro). But it failed in test machines (windows 2000 Pro and Server) with following error Internal Error 2211.quickpatch_generated.

Is it a problem in InstallShield Express? So, I should go for some other version like Developer?

Any feedback for solving the problem would be a help.

Pushparaj

Chandima
12-09-2002, 02:23 PM
What Operating System do you have Express installed on? We have noticed this happens if you build the patch on a Windows 9X system.

pushparaj
12-09-2002, 03:08 PM
My development machine is Windows 2000 Pro and I installed InstallShield Express 4.0 on the same machine.

Update.exe works fine on my development machine.

When we ran the update.exe on test machines (Win 2000, Win 9x) this error comes.


Pujshparaj

Chandima
12-10-2002, 11:19 AM
That's strange. Update.exe should (technically) fail on your development machine as well. The reason this happens is because in some cases when we create the "updated image" msi file, the build doesn't put an entry in the Feature table.

How many files/reg entries are you updating? If it is not too much try creating another QuickPath from scratch. Let me know if this works.