PDA

View Full Version : BDE Merge Problem After ISX4 Upgrade



jjnovak
11-29-2002, 02:28 PM
I just upgraded my ISX Borland Limited Edition 3.03 to ISX 4. The install removed the limited edition and replaced it with the latest. This would not be a problem except that ISX 4 converted my old installation project file then gave me a merge error when rebuilding my program's installation.

ISEXP : error -4075: File not found. An error occurred merging Module 'BDE_PRO.E966F0CB_76B3_11D3_945B_00C04FB1760A:0' for Feature 'AlwaysInstall'.

I downloaded the latest BDE merge file and reinstalled but this didn't help.

I guess I'll have to uninstall it until this is resolved.

Chandima
12-02-2002, 06:14 PM
When you say you got the latest BDE merge file, do you mean you have the latest msm file? If so, find it's location on your machine. Then:

1. Launch Express
2. Go to Tools->Options->File Locations on the main menu
3. Set the Merge Module locations to point at the location where the BDE msm file is
4. Create a new project
5. Go to Redistributables View

You should see th BDE merge module. If you do, open your existing project and build. Should not get this error anymore.

jjnovak
12-02-2002, 06:26 PM
I downloaded the BDE Merge Module Setup application (1.50.80.0) from the Install Shield site.

Chandima
12-02-2002, 06:55 PM
You have Delphi installed right? If so, try the following:

1. Uninstall the BDE merge module from your system (from Add/Remove Programs).
2. From Add/Remove programs, select Express and press Change
3. Select Modfiy
4. Set the appropriate BDE feature to install
5. Complete the setup
6. Launch Express and go to Redistributables View

You should see the BDE module.

jjnovak
12-03-2002, 05:28 AM
No, I don't have Delphi installed. I use Borland Builder versions 4 and 6 on the same machine. The ISX Limited Edition was replaced by the ISX 4 install so it's kind of hard to switch back and forth. I still need to use the ISX LE. The next time I get a break, I'll try what you suggested. Thanks.

jjnovak
12-11-2002, 06:21 AM
Problem resolved by setting the BDE merge module path! Thanks.