PDA

View Full Version : Windows Installer Versions



patward
11-26-2002, 04:39 PM
I am testing an installation on older versions of Windows. My installation includes Windows Installer, and is configured for version 1.2. My test machine has Windows 98, with Office 2000 installed. I am get the following message:

This installation package canot be installed by the Windows Installer service. You must install a Windows service pack that contains a newer version of the Windows Installer service.

I expected Windows Installer to just install a later version of the Installer software. And, if I change to Windows Installer 2.0, it does, and everything works fine. Is this a bug, or expected behavior?

I am trying to use the older Windows Installer to avoid reboots with later versions of the operating system.

Chandima
11-26-2002, 05:06 PM
This seems to be a problem with the 1.2 engine re-dists itself. A number of similar posts popped up in the 3.x forums awhile ago and it was just the redist complaining about something. Couldn't quite narrow down what the cause was either. Microsoft KB article Q229819 indicates it's DCOM related but nothing specific. The KB is for the same problem with the Office 2000 install. So this rules out that the Installshield Setup.exe is doing something wierd. I'm afraid that's all I know about the issue.