PDA

View Full Version : Error processing Merge Module



valiot
11-25-2002, 12:28 PM
I get the following error when building my setup:

ISEXP : fatal error Error merging Microsoft OLE 2.40 for Windows NT(TM) and Windows 95(TM) Operating Systems with module ID \Program Files\Common Files\Merge Modules\OLEAUT32.MSM
Express\SingleImage - 1 error(s), 0 warning(s)

This project worked fine under V3.5 but now that I upgraded the project it doesn't work...

Michael Aivaliotis

Chandima
11-25-2002, 12:44 PM
Is Express 4.0 installed on the same machine you had 3.5x on?
Is this the only merge module in your project?
In Express, on the main menu, go to Tools-> Options-> File Locations. What are the paths mentioned in the Merge Modules section?

valiot
11-25-2002, 12:48 PM
The following field entry exists for Merge Module Locations (current user):

C:\Program Files\InstallShield\Express\Modules\i386,C:\Program Files\InstallShield\Express\Objects,C:\Program Files\InstallShield\Express\Modules\i386\Japanese,C:\Program Files\InstallShield\Express\Modules\i386\German,C:\Program Files\Common Files\Merge Modules

And to answer your other questions, this is the only module enabled. However enabling other modules seems to have the same result. Also this installation is on the same machine. I had to uninstall 3.5 because the 4.0 installer wouldn't let me upgrade.

Michael Aivaliotis

Chandima
11-25-2002, 01:00 PM
What happens if you create a new project, include this module and build? Do you get the same build error? If so, what is the build error number?

Do a search on your machine for a file named mergemod.dll. Try registering this file and re-building.

Also, try creating an Express project in a location like C:\Test, include this module and build. Do you get the same error?

valiot
11-25-2002, 02:03 PM
Well, re-registering mergemod.dll fixed the problem. I don't know why this would get unregistered? Anyway, Thanks for the quick response.

Michael Aivaliotis