PDA

View Full Version : BDE Merge Module Install Error - Delphi 7



Greg Eytcheson
11-20-2002, 10:47 PM
I just upgraded from the InstallShield Express Borland Edition that comes with Delphi 7 Studio Enterprise to InstallShield Express v4 and cannot get the BDE Enterprise module installed. I uninstalled the Borland Edition before attempting to install the v4 edition.

After the "regular" install, it gives me the error "Setup could not detect a valid version of Delphi or C++ Builder. To use this module, you must have an Enterprise version of Delphi or C++ Builder installed. Installation cannot continue." After clicking OK, it says: "The wizard was interrupted before the Borland Database Engine Merge Module could be completely installed. Your system has not been modified. To complete installation at another time, please run setup again."

I definitely have a valid, registered, legal, version of Delphi 7 Studio Enterprise installed. I tried running Add/Remove Programs - InstallShield Express - Change - Repair, and got exactly the same error.

Any ideas?

Thanks,
Greg

Chandima
11-21-2002, 10:47 AM
Delphi 7 already has the BDE merge module. The BDE module distrobuted with Express is only for Delphi 5. Please search your Borland folder for *.msm. Once you find it:

1. Launch Express
2. On the main menu go to Tools->Options->File Locations
3. Enter the path you found in the Merge Modules path
4. Close the options dialog
5. Go to Redistributables view

You SHOULD see the BDE module. Please let me know.

Greg Eytcheson
11-21-2002, 11:06 AM
Thank you! Adding the path as you recommended worked perfectly!

FWIW, I found them at:

:\Program Files\Borland\Delphi7\MergeModules

Regards,
Greg