PDA

View Full Version : Newbie Question - Advertised Shortcuts



stroulger
11-07-2002, 01:07 PM
Sorry if this a silly question, but I am having a little problem with all of the setup I have tried to repackage.

I have repacked a number of setups (WinZip, Acrobat Reader,etc) on a completely clean PC and as Administrator. These have been repackaged by the Legacy Conversion Wizard, with no errors.

I have next added the resulting msi to the GPO of my users and set the package to 'Advertise'

When a user clicks the icon the package always fails at the end with a problem with the short cut.

What am I doing wrong ????

nicholas_ong
11-07-2002, 01:48 PM
Do you have any problems with the application if you installed it interactively (by double clicking on the msi)?

What did you mean by advertise? There's only assign or publish of msi applications in the GPO. Please elaborate.

stroulger
11-10-2002, 11:19 PM
The packages install perfectly when the msi is double clicked.

I ment to say that I am trying to 'assign' the msi ('Publishing' is working fine with the same package).

Unfortunately, most of my users would struggle to do anything as advanced as installing published applications :)

judoboy
11-28-2002, 11:18 AM
I have the same problem and I'm trying to solve it since one Week.

1) I use Repackager to create a .inc
2) I use Developer to create a .msi
3) I use GPO to install my application : I use assignation


I reboot the computer and I'm logging with user right
The shorcut of my application is on my start menu.
But if I click on the link, I have a MSI error with the shortcut, and the application didn't launch.

If a look in the folder, all my application's files have been installed.


If I use "Control Panel" with the user to add the application, all is working fine.

How does I create the msi in order to use assignation correctly, without error.

Thanks

Ludo

nicholas_ong
11-28-2002, 11:32 AM
Check the application logs in event viewer, it will provide you with the component codes that is self healing.

There should not be any major differences between an assigned and a published package. The only difference is that current user settings have to be inserted for each new user that uses the application. This should only happen once for the user.

stroulger
12-01-2002, 05:15 AM
I found the answer in another forum.

Using developer, delete the Custom Action 'ISInitAllUser' sections which can be found in Sequences -> Installation -> User Interface and Sequences -> Installation -> Execute

Seems to do the trick

judoboy
12-02-2002, 03:59 AM
That is the good solution !!

Thank you very much !!

Ludo

malves
12-07-2002, 03:40 PM
I am also having a similar problem. I have repackaged Business Objects 5.1.5 and used Install MOntoring with the Legact Converter. The package converted. Here is what the event viewer says with MsiInstaller as the source when I click on the shortcut on a clean machine. After an older version was removed and the new verion was installed with Intellimirror.

"Detection of product '{09CA707F-B8AF-43C8-AD0E-5F34AC03F965}' feature 'BusinessObjectsNewFeature' failed during request for component '{F94CE054-F81A-4E77-A83C-EB157EDE7FF1}'"

The component GUID corresponds with BusObj.exe the main executible for the program. I have tried to Disallow Advertisingon both the shortcuts and the Feature but still get the same results that generate a Shortcut Problem dialog saying "Fatal error initializing".

Any ideas on how to resolve? I'm including a screen shot BMP of the event log.