PDA

View Full Version : Active X ADODB



dmoring
09-11-2002, 09:11 AM
I'm having trouble getting my VB6 app to work with InstallShield Express. I need to create an object for .db connection through Jet4. When I scan the project it adds Jet 351 MM, but all of the Jet4 .dlls. I manually added Jet40 MM and MDAC 2.6 is automatically added. When I install on a WinME machine, I get error: Cannot create ActiveX Object in the function. VB it is having a problem with is:
Set conn = New ADODB.Connection
With conn
.Provider = "Microsoft.Jet.OLEDB.4.0"
.Properties("Jet OLEDB:Database Password") = "xxx"
.Open dbFile
End With

HELP!

Chandima
09-12-2002, 04:51 PM
What happens if you deslect the Jet351, Jet 40 and MDAC 26 merge modules and just use the MDAC25 merge module. MDAC 25 contains jet drivers and just MIGHT make a difference. Worth a try...

dmoring
09-12-2002, 06:57 PM
Thansk for the advice but I already tried that. How about just Jet4 and 2.6? Nevermind, I tried that too... now the error is failure to create ~ Object in ~ (first time I've ever seen that with the tildes!).

Chandima
09-13-2002, 01:06 PM
Open your vbp file in Notepad and see what file it specifies as "Objects=" and "References=". See if all these files are in your setup either through individual dll's (or ocx), Jet, MDAC or other merge modules. Maybe our scanner is missing a file or deliberately (which would be a bug if it fixes the problem) filtering a file your VB project needs to work.

dmoring
09-16-2002, 07:09 PM
It does not appear to be including the schocvw.dll or the .ocx includes. Shouldn't these be included in the MergeModules?

Reference=*\G{00020430-0000-0000-C000-000000000046}#2.0#0#..\..\WINNT\System32\STDOLE2.TLB#OLE Automation
Reference=*\G{00025E01-0000-0000-C000-000000000046}#5.0#0#..\..\Progra~1\Common~1\Micros~1\dao\dao360.dll#Microsoft DAO 3.6 Object Library
Object={EAB22AC0-30C1-11CF-A7EB-0000C05BAE0B}#1.1#0; shdocvw.dll
Reference=*\G{00000205-0000-0010-8000-00AA006D2EA4}#2.5#0#..\..\WINNT\ServicePackFiles\i386\msado15.dll#Microsoft ActiveX Data Objects 2.5 Library
Reference=*\G{AC3B8B4C-B6CA-11D1-9F31-00C04FC29D52}#2.5#0#..\..\Program Files\Common Files\System\ado\msjro.dll#Microsoft Jet and Replication Objects 2.5 Library
Reference=*\G{5C65924B-E236-11D2-8899-00104B2AFB46}#1.0#0#..\..\WINNT\System32\wbem\wbemcntl.dll#WMICntl 1.0 Type Library
Reference=*\G{2A005C00-A5DE-11CF-9E66-00AA00A3F464}#1.0#0#..\..\WINNT\System32\COMSVCS.DLL#COM+ Services Type Library
Object={5E9E78A0-531B-11CF-91F6-C2863C385E30}#1.0#0; msflxgrd.ocx
Object={831FDD16-0C5C-11D2-A9FC-0000F8754DA1}#2.0#0; mscomctl.ocx
Object={67397AA1-7FB1-11D0-B148-00A0C922E820}#6.0#0; msadodc.ocx

johnhind
09-17-2002, 02:09 AM
What is the value of your variable "dbFile" in your first post ?
What do you mean by a ".db connection" ?

This might be your code at fault. Does it work on Win2k or XP ?

John

dmoring
09-17-2002, 05:04 AM
Yes, it works fine. The dbfile is the connect string, to wit:
dbFile = App.Path & "\Race.mdb". Re: Last Post - I don't need the DAO ref anymore, and so will remove. Also, if I remove the reference in IE to COMSVCS.DLL#COM+ Services Type for 98/ME do I need another reference for C+?

dmoring
09-23-2002, 08:06 AM
I am still stumped...any body with any ideas?