View Full Version : Comsvcs.dll failing

09-09-2002, 09:22 PM
I am trying to install a relatively simple VB app. It installs fine on Win2x but when I move to 98/ME, I get a comsvcs.dll error (several times) during installation. I click 'Ignore' and the program installs and runs fine in all areas. Ideas?

09-10-2002, 06:49 AM

comsvcs.dll is a system specific file and according to the Microsoft dll help library (http://support.microsoft.com/default.aspx?scid=/servicedesks/fileversion/dllinfo.asp) only exists on windows 2000 and XP.

I do not think that you need to include this file, but I would at least suggest making sure that the file only installs on windows 2000 and XP.

To do this, right click the file and deselect unsupported operating systems from the Advanced tab of the properties dialog.

Hope this helps.


09-11-2002, 05:19 AM
Thanks! That worked. Now the ActiveX Object (ADODB connection) can't be created in ME (probably 98 too). Still installs fine in Win2x. I am using Jet 3.5, 4.0 and it automatically includes MDAC 2.6_ENU. Also, I have all of the .dll's in separately from the MM (due to scanning the project). Should I remove them?

09-12-2002, 04:48 PM
The following KB article says you should NOT redistribute this file:


Please search the microsoft website for more information on this file. Does your application reference or communicate with a COM+ component? If so maybe you have to install the COM+ component on the targte machine. All the searches I did that referenced this file were Win2K.

09-13-2002, 07:25 AM
Yup, that worked... THANKS!