PDA

View Full Version : Replacing Components with available Merge Modules



Jeff Barth
09-09-2002, 08:30 PM
I am using IS Developer 7.04, and originally posted this to the IS Developer forum. But another user suggested I post it here, in the hopes of finding more repackager users.

I am trying to use Repackager to simplify installation of SAPI4 (MS Speech API), and possibly combine it with another legacy setup program. While importing the *.inc file, part of the output is the statement: Replacing Components with available Merge Modules.

The resulting package contains merge modules for stuff that I don't think should be there at all, in particular three MSDE 2000 SQL Server merge modules and a MAPI merge module. This is causing me problems in my setup.

I want Repackager to repackage the files that were installed by the legacy setup program. I want exactly those files, no more and no less. How can tell Repackager/Developer/Admin Studio to not substitute Merge Modules for the files I want to repackage?

thanks,
--jeff

Kirkpatrick
09-10-2002, 05:34 AM
Jeff,

In the OPTIONS.ini file where you are running Repackager the [General] Section looks something like:


[MMExclusions]

[General]
UseSrcFolder=Y
EnablePathVariables=Y
UseHKCUProxy=N
LimitedUI=Y
SISAuthor=New Horizon System Solutions
OtherFilesNewComponents=N
UseMergeModules=Y




You will probably want yours to state N for the MM part.
UseMergeModules=N


Try capturing the installation now and see if that works.

If not then there is a Section in the same INI file for Merge Module Exclusions if you know exactly what you want to do (or not do)

Good Luck!
:)

Jeff Barth
09-10-2002, 04:12 PM
Great suggestion. When I read your post I thought I was home free. My options.ini did not have any UseMergeModules option, so I added it (UseMergeModules=n). After running Repackager, I looked at the the resulting options.ini, and it did have the UseMergeModuels=N.

But when I opened the *.inc file in Developer, Developer still included the same Merge Modules. It sounds like this may not be a Repackager issue, but rather a problem with IS Developer -- it won't be the first time :mad:

Thanks for you suggestion.
--jb.

praveenl
10-01-2002, 02:55 PM
If your repackaged setup has readme.txt then their may be chances that SQL merge mods are getting included because of this file. Just a guess. For a workaround get rid of the readme.txt, import the inc project, then manually add the readme.txt file. Rebuild .msi file.