View Full Version : Error 13000 Product Not Registered With the Agent

09-07-2002, 10:12 AM
I am getting Error 13000 at program startup when I run the AppStart option (Product Not Registered with the Agent). It does the same with the AppMenu option.

I've read and followed the knowledgebase article regarding this. The product IS registered, the version number IS registered. It shows up correctly in the Test Utility and on the web site. In fact, when I first installed the app, the ISWizard suggested that I check for updates, I did so, and IT FOUND UPDATES. The product/version is obviously registered. I only get this error later, aftert the ISWizard terminates, when I run my app.

This is the first time I've seen this behavior in all my testing. It seemed to work fine before. Does anyone have suggestions?

09-07-2002, 11:34 AM
Here's what I found:

My product had just gone through a major upgrade, so the product code changed. When you change the product code, you also need to change it in the call to AppUpdate in the application. Minor upgrades are recognized just fine since the product code hasn't changed.

I hope this helps someone.