PDA

View Full Version : still having trouble with reg keys in packages.



GMcKim
08-26-2002, 09:47 AM
I am using active directory to install software via policies. I am having the most trouble with Winzip. When winzip installs via the policy, all the current user settings go in the regkey area of the HKU - machine profile. When the user logs in and goes to run winzip, it goes through the whole install wizard setting up associations and toolbar configs. I downloaded the trial version of admin 3.5 and it is doing the same thing. My question is, how do setup the policy or the package to put reg entries in the HKCU tree during the initial install. There is keys in there inside the package, but like a said, the install thinks the machine account is the current user. What is the difference between using the assign or publish inside the policy. The work around that I am doing right now is once the software is installed, I go to add/remove programs and run a repair on the package. This puts the reg keys in HKCU and everything works great. I would like to avoid this last step if at all possible.

nicholas_ong
08-26-2002, 11:15 AM
It sounds like you're assigning Winzip to all computers. The package that we have here does the same but the self repair to insert HKCU settings was a quick 3seconds. You may want to look at the components to see if something else is being reinstalled if it's taking a long time as you've suggested. In any case, if you want to get rid of that completely I would suggest that you extract the HKCU settings into a registry file, copy onto the local drive and create a run or runonce key to do a silent register when the user logs on. Hope this helps.