PDA

View Full Version : Service will not start



LawrenceH
08-06-2002, 08:23 AM
Does anyone have a fix for services not installing after a repackage? I have three services that need to install/start at installation time, but I get the "xxxxx service failed to install....verify that you have sufficient privileges...." The repackage was done as an administrator. I have tried recreating the services using the Component Wizard to no avail. Can anyone give me a few suggestions?

nicholas_ong
08-06-2002, 11:10 AM
From my experience, services are generally not captured properly and alternatively can be imported as registry entries from HKLM\SYSTEM\CurrentControlSet\Services. You will have to identify the service you require and all registry entries belonging to it.

You should also find the entries in the standard.nir file.

jeronimo
08-08-2002, 07:54 AM
I've had the same problem, like many people I think. I've tried to play with the registry entries, without success. Check the services you are trying to install are not file system driver or driver services because Windows Installer doesn't support these types of services. I've read threads (in the Developer forum) of people who have created their own DLLs to install those services.
I think they've used the InstallScript UseDLL function and the Windows API functions CreateService, OpenSCManager, OpenService etc...