View Full Version : Error 1334. Anybody had this & resolved it?

08-02-2002, 12:48 AM
I have an error message as follows:

"Error 1334. The file 'xxx.xxx' cannot be installed because the file cannot be found in the cabinet file 'Data1.cab'. This could indicate a network error reading the cdrom, or a problem with this package."

The file is present on the system.

I have looked at the security settings, both the 'system' & 'everyone' users,all have admin rights. I have check all the paths, variables & the table editor, all looks correct.

I have even repackaged the same app a second time around, the same error message appears but on a different file. One was an .exe and the other a .dll. They have no com settings, no file extensions.

I have removed both files from the MSI & re-added them, same error message appears. I have even remove the file from the package, but the error appears on a different file in the package.

These packages, both compile & are validated correctly with NO errors being produced.

I am installing the MSI package on another PC, with admin rights.

The error message appears when the msi is copying files.

Can some one help me.......!

08-09-2002, 06:59 AM
When you compiled your package, is it compressed or uncompressed? On installation, are you running it from a network location? Have you tried copying the entire MSI to your local drive and executing from there? Just a few suggestions, hope it helps.

08-11-2002, 11:55 PM
The package is compressed.

The package is compiled on one PC, then I have shared this directory, then connected to it from the other PC. (How I normally do it)

I then have copied it to the local drive, but it still isn't working


08-12-2002, 08:12 AM
I feel for ya, btw what application is this?

08-20-2002, 04:12 PM
What is the name of the file that the MSi is displaying an error for? Did you make sure that file is in the cab?

09-09-2002, 07:04 PM
This error is produced when you have files that are in components and are not marked as 'key files' being copied to the [installdir]. For each error that occurs, you need to make a new component, add the file to it that is causing the errors, set it as a key file. Also, put the new component into the setup area as well.

This will resolve the 1334 error messages that are occurring.

This then produced another similiar error when building the cab file. I had to rebuild the cab file in the uncompressed mode, as the compressed mode did not work correctly.


10-03-2003, 03:17 PM
I have seen this before and it should have nothing to do with whether or not the file is a key file.

Your cab file is more than likely corrupted. Not sure when it is getting corrupted but it definitely.

Your environment is more than likely the cause. Check to see if the server disk is having issues or isolate and create a standalone network with 2 computers and see if you can install this successfully.

Mike Coldewey
03-19-2004, 03:34 PM
Have you checked this note from Microsoft?


03-07-2007, 06:37 AM
ok, here is my experience:

I had error 1334 on msi-installscript projects created from InstallShield DevStudio 9. I have had many tests and I think this is a bug from InstallShield, because looking at all the information on the project (even in direct editor) all seems correct. The uncompressed releases I have works correctly, but not the compressed ones.

I read Q107312 but it didn't help me so much...

In my case, I solved it by recreating a new release of type "Network image" beneath of "Web image". Then new release fails again, but if I delete new release from installshield project, and I rename the old one to the new name, it works.

I don't really understand why does that happens, but I think I have found a workaround.

I hope this helps someone, and sorry for my bad english.

03-08-2007, 09:40 AM
Ok, the problem seems to be when the release is a compressed release, so network image is not compressed by default.

I have another project almost identically, and it works, but not the original one, so I think it's an internal bug of InstallShield, which sometimes corrupts the packaged file.