Results 1 to 2 of 2

Thread: Old Product version in 2009.727.1365 format

  1. #1
    Join Date
    Sep 2010
    Posts
    3

    Old Product version in 2009.727.1365 format

    Using Installshield 2011, we're creating a major upgrade and having problems upgrading software with this Product Version format - 2009.727.1365. We keep getting the standard 'Installed software is newer than product to be installed' message. With IS 2011, the major version has to be less than 255, from what I can gather, and I think the old format we're using is breaking the check for upgrading.

    I've created a test IS project upgrading from 1.00.0000 to 2.00.0000 with no issues, so I'm thinking the issue has to be related to the format of the product version already installed.

    Is there a way to use InstallScript or something to compare our old format with the new one and then do an override?

    Any help would be greatly appreciated. Thanks in advance!!

  2. #2
    Join Date
    Oct 2001
    Location
    Here and there
    Posts
    16,243
    You'll probably need to remove or modify the ISPreventDowngrade major-upgrade item, which is what detects and prevents this kind of version downgrade (and which is usually what one wants).

    A quick test at this end from version 2010.0.0 to 2.0.0 seems to work with ISPreventDowngrade removed, for example.
    Last edited by RobertDickau; 09-22-2010 at 06:16 PM. Reason: P.S.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •