Results 1 to 2 of 2

Thread: Which ant version? Which xerces version?

  1. #1
    Join Date
    Feb 2008
    Posts
    8

    Which ant version? Which xerces version?

    Hi,

    Our previous build engineer executed ant by calling ant.bat/ant.sh scripts from the installanywhere project.

    In an earlier post, an member had alerted me to the 'ant' action: this would execute the ant build file without any intermediary scripts. Sounds great/

    But one question arose: which version of ant?

    If our build script uses ant 1.7 (or 1.8 or 1.9 or whatever), how do I make installanywhere include that version of ant?

    On a related note:
    We had a problem earlier where IA's version of xerces differed from the one in the ant library. The result: IA set the CLASSPATH environment variable to point to 'old xerces, and ant picked up a version of xerces which didn't like the syntax 'file:foo.xml' for 'SYSTEM entities.

    We had to change our syntax because we didn't think we had any control over installanywhere's version of xml parsers.

    thanks in advance.

    bill

  2. #2
    Join Date
    Mar 2006
    Location
    Paris, France
    Posts
    2,142
    If you check your IA installation folder (the resource/ant subfolder) and you will check the ant.jar you'll see that the defauly bundled ANT version is 1.6.2, whereas the Xerces version is 2.6.2 If you use the Execute ANT action this is the version that that will be used.

    So I guess you have two alternatives: you either bundle a different version if needed, but you won't be able to use the Execute ANT action, or you may want to test if it possible to replace the default ANT version (of course, it might completely break your IA installation or your installers). You may want to check directly with Macrovision support, but I'm pretty sure that they won't recommend this, or won't support it (or both).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •