Page 1 of 2 12 LastLast
Results 1 to 5 of 6

Thread: Exit Code -1073741819

  1. #1
    Join Date
    Jun 2006
    Posts
    2

    Exclamation Exit Code -1073741819

    Has anyone seen the return code -1073741819 (0xC0000005 - supposedly Access Violation?) from an InstallShield project during the building of the project?

    If I build the project using the InstallShield GUI, it compiles fine. If I compile it using the command line (IsCmdBld.exe) from a command prompt, it builds just fine.

    However, when we build it using Visual Build Pro, Visual Build Pro says it fails with the return code -1073741819. It catches this return code in the middle of merging in the merge modules.

    We tried just shelling the command line call to a command prompt as a work around and that worked fine to build it. However, then we get the following error when running that install: Internal error 2602. File, Global_Controls_MSMAPI32OCX_f0.7EBEDD2C_AA66_11D2_B980_006097C4DE24.


    A number of weeks back when we upgraded to IS 11.5 from 10.5, we experienced the same problem. Uninstalling 10.5 and installing the 11.5 InstallScript Objects fixed both problems (return code -1073741819 and the Internal error). Now both problems have resurfaced for an unknown reason. No configuration changes have been made to the computer and none of the changes made to the installer are the cause (we rebuilt an old (good) build and it failed to build).
    Last edited by Obishawn; 06-05-2006 at 04:16 PM.
    Shawn Riesterer

  2. #2
    Join Date
    Jan 2007
    Posts
    1

  3. #3
    Join Date
    Jun 2006
    Posts
    2
    I've already been to that thread post. That is not a fix by any means. It simply captures the error code returned from InstallShield and allows you to ignore it. The problem is that the InstallShield build has still failed and my installer is not built. If the point of the step is to build that installer, what good is ignoring that it has failed?

    I actually found a fix that worked when we were using InstallShield 11.5: http://www.obishawn.com/archive/2006...073741819.aspx.

    Unfortunately, that fix did not work for InstallShield 12.0. I actually had to overwrite the MDAC28.msm from the 12.0 installation with the one from 11.5 to fix it. However, that is going to be a problem when we start wanting to support Vista as the 12.0 version of the MDAC28.msm was updated to support Vista.
    Shawn Riesterer

  4. #4
    Join Date
    Mar 2002
    Posts
    40

    Urgent - return code was -1073741819

    Suddenly from this Sunday March 11, 2007, my daily build is broken. The error message is:

    External Program Failed: C:\Program Files\Macrovision\IS 12 StandaloneBuild\issabld.exe (return code was -1073741819)

    It was built successfully on Saturday. Nothing changed between these times.

    I can use IS UI to build it, but on build machine, we don't install IS 12 IDE

    The most wiered thing is all our other 4 projects are built OK.
    If I run IsSABld.exe from command line, no error generated. But it stops at "Building File table". Merge modules and others are not built into the msi. Even I remove all merge module references, I still get return code -1073741819

    C:\Program Files\Macrovision\IS 12 StandaloneBuild>IsSABld.exe -p our.ism -o C:\MergeModules > c:\log.txt

    The following is from log.txt

    Release Builder
    Copyright 1997-2006 Macrovision Europe Ltd.
    and/or Macrovision Corporation.
    All Rights Reserved.

    Build started at Mar 12 2007 04:27 PM

    Created release folders
    InstallShield Script Compiler
    Version 12.0.0.49974
    Copyright 1997-2006 Macrovision Europe Ltd. and/or Macrovision Corporation. All Rights Reserved.
    (null)
    Compiling...
    Setup.rul
    C:\Setup\common\installscript\Setup.rul(1865) : warning W7503: 'StartTE' : function defined but never called
    C:\Setup\common\installscript\Setup.rul(1865) : warning W7503: 'DoesMWExist' : function defined but never called
    Linking...
    Setup.inx - 0 error(s), 2 warning(s)
    ISDEV : warning -4371: There were warnings compiling InstallScript
    AdminExecuteSequence table successfully built
    AdminUISequence table successfully built
    AdvtExecuteSequence table successfully built
    AdvtUISequence table successfully built
    InstallExecuteSequence table successfully built
    InstallUISequence table successfully built
    Directory table successfully built
    Feature table successfully built
    FeatureComponents table successfully built
    Component table successfully built
    Loading File table
    Building File table
    MWServiceCenter\Release - 0 error(s), 1 warning(s)
    Log file has been created: <file:C:\Builds\Debug\xx\Release\LogFiles\3-12-2007 04-27-59 PM.txt>


    I run out of ideas. Any help is appreciated.
    Lily

  5. #5
    Join Date
    Mar 2002
    Posts
    40

    SP1 for IS 12 Stand Alone build engine

    After installed IS 12 IDE to a new machine, open my Basic MSI project and click Build icon, I reproduced the build failure(return code was -1073741819). I think if I install IS 12 SP1, the problem will be gone. But the thing is we don't have a SP1 for IS 12 Stand Alone build engine.

    Exception ACCESS_VIOLATION (0xc0000005)
    at address 0x72e5e84f trying to write address 0x06fcb150.

    File : C:\Program Files\Macrovision\IS12\System\isdev.exe
    Version : 12.0.0.49974
    Exception : c0000005
    Address : 72e5e84f
    Access Type : NA
    Access Address : 06fcb150

    Registers : EAX=06fcb150 CS=001b EIP=72e5e84f EFLGS=00010246
    : EBX=00000000 SS=0023 ESP=0012b41c EBP=0012b428
    : ECX=72e73575 DS=0023 ESI=06fcb150 FS=003b
    : EDX=ffffffff ES=0023 EDI=06543c4c GS=0000

    Stack Trace : 72e5e490 72e5e672 72e7854f 72e784a4
    : 72e785b0 72e78aa0 72e5f764 72e5f932
    : 72e5f874 72e5e12b 72e768c4 72e76be7
    : 68ff0d40 68ff0c49 68fef267 68fd98e1
    : 68fd9261 68fd8bab 68fd87b2 68fd8a33
    : 68fd8781 68fd85fa 6900408f 69004010
    : 68d6e4f5 68d6dfb1 68d6d588 68d6b4b0
    : 68db85ee 68d801c8 68d7e50c 68d31333
    Lily

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •